1

After upgrading to Monterey I cannot save files using Safari or Brave Browser (it's browser on Chromium engine). Downloads are starting forever and never finish. I waited like an hour to test it.

What is more, I found that I cannot save copy of image using Preview. I can press button but nothing happens.

What is interesting, I can save files using Chrome or Firefox, browsers that I didn't use for a long time but have them installed.

What might be the problem? Some kind of permission to folders problem?

4
  • Do all browsers use the same download folder? Can you access the folder from Finder?
    – nohillside
    Nov 9, 2021 at 10:02
  • All browsers use the same folder and I can access it from Finder.
    – omikron
    Nov 9, 2021 at 18:12
  • What is interesting, I have set Safari to ask where to download file each time, but when I changed it to store to download folder, it works!
    – omikron
    Nov 9, 2021 at 18:39
  • Thanks for fixing the edit. If you have configured any browsers to save files to a location other than ~/Downloads can you update this to list for [each failing browser the full path to the non-default save folder]()? I’m thinking if you have chosen a secured location, you have to adjust your full disk access or choose a folder that’s. It protected by the OS for which to save these files.
    – bmike
    Nov 10, 2021 at 11:21

4 Answers 4

1

The only solution I found is to reset the settings to the default download folder

1
  • Yeah, I did that too for now, but it's workaround not solution. Question is, where is file saved temporarily?
    – omikron
    Nov 10, 2021 at 10:41
0

I don't know if you tried this: restart to make sure it is not a temporary system bug.

I have had this "saving image" issue happened to me in a chatting software, where I could not save images directly via that app, but opening with Preview and then saving has always worked for me *Using the "Export" menu option, not "Cmd + Save"

I am currently using Preview and it works fine, and the chatting software was updated and is working fine as well. Downloading works fine for me too...Assuming that it works well before the update, then access to the folder should not be a problem.

Perhaps you forgot to click the pop up to "allow download on this site", which can be changed in Safari 's Websites setting.

1
  • I restarted several times. It is connected with two different browsers I used recently.
    – omikron
    Nov 9, 2021 at 14:00
0

What really helped was to set ownership of all things in my home folder to myself again, as suggested here: https://apple.stackexchange.com/a/51862/391874.

sudo chown -R $USER ~/
0

It seems to be a bug with the current Safari as the latest Safari Technology Preview [Release 135 (Safari 15.4, WebKit 17613.1.7.3)] doesn't have this issue. The interim solution is to set the dafault download folder instead of asking for each download.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .