5

I have an iPhone 8 with a mobile internet connection and an MacBook Pro 13, which is connected to the internet via the iPhone.

On iPhone, I turn on the Personal HotSpot, and then on MacBook I connect to my iPhone, and that’s how I get the internet connection for my laptop.

The problem is that when I close the lid of my laptop for a few minutes, the connection is broken (I no longer have internet on my laptop), and in that situation I am forced to manually re-start the hotspot on my iPhone. Only then does my iPhone show up as an available connection on Mac.

This is obviously not how it’s supposed to be, so I must be doing something wrong. What I want is to have the connection between my iPhone and MacBook persist (stay connected), even if I close the lid for 5 minutes.

8
  • This sounds like it's working as expected. When you close the lid on the MacBook, it goes to sleep. The iPhone will turn off the hotspot once there are no active connections to it any longer. You can likely tell the MacBook not to sleep when you close the lid, that might keep the connection active... but for the most part this all sounds to be working as expected.
    – Charlie74
    Sep 15, 2021 at 13:15
  • 1
    @Charlie74 Bummer. This behavior is quite annoying. Every time I go to the bathroom or kitchen or anywhere, I have to close the lid, so every time I return, I have to manually re-establish the connection, first on the iPhone, then on the MacBook. I wish Apple made an exception for connections between its own devices. Sep 15, 2021 at 13:50
  • Out of curiosity @Šime Vidas, why the need to close the lid? Is it for security reasons? Would simply using Control - Command - Q to lock the screen work instead?
    – Charlie74
    Sep 15, 2021 at 16:29
  • 1
    The automatic disconnection from iPhone personal hotspot soon after closing of MBP’s lid is standard and therefore unavoidable. However, you should not need to restart your iPhone hotspot for MBP to recognize the hotspot each and every time MBP is automatically disconnected. Not sure what the exact solution to this part of your problem is but it is not normal. I have also experienced it occasionally when using my 2019 MBP together with my iPhone X until a few months ago but it disappeared after one of the updates to Big Sur.
    – Alper
    Sep 15, 2021 at 17:59
  • 1
    @Charlie74 I actually did not think of doing that. Yes, that sounds like a great solution. I’ll start doing that. Sep 15, 2021 at 19:55

2 Answers 2

-1

This might be fixed by enabling Power Nap. Checkout: https://support.apple.com/guide/mac-help/what-is-power-nap-mh40773/mac . This will only work when connected to a power outlet.

3
  • 1
    Power Nap seems to be enabled by default. At least I don’t remember enabling it. (It’s in System Preferences > Battery > Power Adapter > Enable Power Nap) Sep 15, 2021 at 13:40
  • Power nap is possible, and separately set, for power adapter and battery...
    – Solar Mike
    Sep 15, 2021 at 14:38
  • 1
    Enabling Power Nap does not solve the described automatic disconnection problem.
    – Alper
    Sep 15, 2021 at 17:37
-2

So closing the lid can be going into hibernation or just sleep where some things can continue.

If closing the lid on your macbook is set to hibernate then you should change that.

2
  • 1
    macOS seems to handle these things automatically. I have not found a sleep vs. hibernation toggle. The only option that might be relevant is “Prevent computer from sleeping automatically when the display is off” (in System Preferences > Battery > Power Adapter). This option is disabled for me. I guess I could try turning it on, but the system warns me that it will use more energy and suggests sticking to the defaults, so that can’t be the best solution to my problem. Sep 15, 2021 at 13:47
  • @ŠimeVidas The option you mention is only available in the adapter mode, i.e. when the MBP is charging. On the other hand, having it enabled when charging does not prevent a closed-lid MBP from automatically disconnecting from a hotspot either.
    – Alper
    Sep 15, 2021 at 18:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .