0

I am trying to remotely access/control a desktop Mac computer from my MacBook Pro.

I am able to do this by turning on "Screen Sharing" in System Preferences and then connecting to a server from the Finder with address vnc://ip-address/ where ip-address is the IP address of the desktop Mac I'm trying to connect to.

However, when the desktop Mac is connected to a VPN, I am unable to access it from my MacBook Pro. Whenever I try connecting to the desktop Mac, I keep getting timeout errors. I have tried every single thing I could think of, but simply being connected to a VPN seems to prevent access to the desktop completely.

Is there any way to remotely control a Mac that is connected to a VPN?

6
  • Is "remote" from another physical location or form the same LAN? And what is the VPN product being used?
    – Gilby
    May 30 at 23:37
  • By remote I mean on the same LAN, although (in a separate question) I am interested in knowing how to do this from another physical location also... The VPN I'm using is Mullvad May 31 at 0:12
  • 1
    Can you connect to a file share on the desktop Mac? If no, then Mullvad is forcing all traffic to use the VPN and there will be a Mullvad setting somewhere to allow local LAN network. mullvad.net/en/help/using-mullvad-vpn-app under Preferences - Local Network Sharing
    – Gilby
    May 31 at 0:27
  • I’ve had some luck using TeamViewer from and to a VPN. There’s a free version available.
    – JW.
    May 31 at 2:02
  • @Gilby that setting was exactly it! So Mullvad was blocking local LAN connections, I guess. Feel free to post that as an answer. Teamviewer also would probbaly work May 31 at 2:41
1

Consumer VPN providers have an app with some configuration choices. One such choice is whether all network traffic is or is not sent via the VPN.

If all network traffic is sent via the VPN (seemingly the obvious secure setting) then it really means ALL traffic is sent via the VPN and the computer will be logically separated from the rest of the local LAN. So local file sharing or screen sharing can't work.

Mullvad has this option. In Using the Mullvad app there is this screenshot:

enter image description here

Local network sharing needs to be enabled.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .