1

I have just fresh installed an ubuntu 18.04 on my desktop and decided to try connecting each other (my macbook pro) via SMB.

To my surprise, when I connected to my mac, using my ubuntu desktop, the Macintosh (the disk itself), and the home folder, along with the public folder is completely accessible.

The problem is, aside from enabling the smb file sharing on my macbook pro, I have not added anything to allow for file sharing, aside from the public folder, which is the only entry on the file sharing settings.

How do I prevent access from the disk, and the home folder?

1

You can remove all the default shares easily from the system preferences. Search for sharing and then configure (by selecting and then pressing the - ) to remove each share you don’t want to be active.

Then you can leave sharing on and just add the specific shares you want.

Here is an article with a picture showing what you would select and then use the + - control below the shared folder to remove that specific share.

If you granted more permissions editing the config file and didn’t save a backup copy, you can recover an unmodified version of that from back up or from the installer / recovery HD as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .