3

When I right-clicked a folder and choose the services -> New iTerm2 Window Here option in the menu, I am getting two iTerm2 windows like this.

enter image description here

But I don't need that root level terminal here (The right side terminal of the image), because I only need this folder path terminal only. How can I stop this behavior?

9
  • When you open iTerm2 from Applications, have you 2 windows or only one?
    – user415185
    May 7, 2021 at 4:24
  • Do you want it gone? Canonical ⌘ + W to close active window. May 7, 2021 at 4:43
  • What version iTerm 2 are you using? It sounds like you may have more than one Profile being loaded. You can check the profiles in the menubar under Profiles
    – adamxweb
    May 7, 2021 at 4:46
  • @Jean_JD Only one. May 7, 2021 at 7:26
  • 1
    At first glance and based on my understanding of circumstances isin’t it expected behavior? You give command for a new window and you get new window in addition to existing one? May 7, 2021 at 9:23

2 Answers 2

4

There is open issue iterm2 opens two window or two tabs when launched from services where possible workarounds are described (also root cause of the problem as well).

From productivity point (if you end in shell anyway) you could consider switching to console based file manager (like vifm, ranger, nnn, Midnight Commander etc). You will get productivity boost from relying on keyboard only. There is also command-line fuzzy-finder fzf which could be handy.

0

I found a solution that works, I left iTerm2 Settings > General > Startup as Use System Window Restoration Setting and also left Advanced > Enable session restoration on. I changed the setting under Advanced > Open a window at startup? to No. Now everything works as you would expect, I startup iTerm2 and it opens one window, I quit and open a folder from Finder in iTerm2 and it starts with that directory and only one window. Hope it helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .