0

Whenever I open the terminal a new window automatically opens up, I'd like to turn it off so that when I open the terminal I don't get a window and have to manually choose one from the shell menu.

The reason is that I'm opening a 3rd party application which opens an REPL in the terminal, and thus when the app opens the terminal I get two windows, one is the REPL which I want, and the other is another default window which I don't.

2

In Terminal's General preferences, go to profiles and create a new profile (let's call it "exit"), then under the Shell tab check the "Run command" option and enter "exit" with Run inside shell checked and "When the shell exits" set to "Close the window."

enter image description here

Then under General preferences, under "On startup" simply choose your new "exit" profile. This will still briefly open a window, but there's no way to have Terminal on launch do absolutely nothing.

You might want to check out iTerm2.

  • When I first read this, I though I'd end up in an endless loop however that wasn't the case. Only the first window when initially opening Terminal was closed and subsequent windows are of my last default, as it's just the startup profile not the default profile that's changed. So to minimize the opening window being a distraction, I minimized the Windows Size on the Window tab opening size to 20x5, as it wouldn't take any lower values. Anyway, I personally do not need this behavior however it's still worth a +1 as an interesting workaround. – user3439894 Aug 4 '16 at 17:48
  • interesting hack! – Thoth Aug 4 '16 at 18:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .