I was trying to get apps to not pop up on the MacOS dock,even when they weren't closed and I found a thread with the same question as me. I looked through the answers area of the thread and this is what they said in the answers area:

This question references How to hide a specific active app on OS X (has to be reversible)?

This solution worked for me, but it might depend on the application in question. I tried it with a 3rd party app called "Burn" and it worked.

  1. Go to your applications folder and right click (control-click) on the app you wanna hide from the dock.

  2. Click on Show contents. You should now be able to see "inside" the app's files.

  3. Open the Info.plist file in the Contents folder with TextEdit (right click -> "Open with...")

  4. Go to the very bottom of the file and find the last two lines which should say:


  1. Now insert this before these two lines and save the file.


After this the app's dock icon will not be shown anymore. Keep in mind that you will need to use the Activity Monitor or Terminal (killall <appname>) to quit the app if you close the window.

If closing the window quits the app, you can press cmd + h to hide the window. This should make your app completely invisible.

To make it visible again, just remove those two lines again and the app should behave like before.

Source: Link

so, I was stupid and did this on almost all of my apps, without opening any of them in the process, and now they all won't open at all no matter what I do. I've removed the text, I reinstalled the apps, nothing worked.. Please tell me how to fix this, I need this laptop for work as it is my main machine.

  • Are you on macOS 10.14 or below? Or did you both disable SIP and remount the root filesystem/snapshot? If neither, you shouldn't have been able to edit the info.plist of any Apple apps, and something else, really weird is going on here. Mar 6, 2021 at 21:53
  • @Wowfunhappy, I am on the latest MacOS macOS Big Sur -11.2.2 Also, No I have not tried to disable SIP and remount the root filesystem/snapshot, because I don't know what do you mean, and I have Anti-virus, does that affect anything? I just want to see if it does just in case. Mar 7, 2021 at 1:37
  • Do you not have a backup that you can restore?
    – benwiggy
    Apr 5, 2021 at 21:06

1 Answer 1


That previous Q&A should be flagged, I guess, to indicate that it's no longer a good idea. Apps are now digitally signed and notarized, and I'm guessing that editing the .plist invalidated the signature, so Gatekeeper (a macOS feature) won't let them launch anymore.

Have you rebooted the Mac? That might help. I would delete all of the apps that you modified, reboot the Mac, and try reinstalling one of them.

Then I would download and install "ArchiChect" from The Eclectic Light Company. Howard Oakley, who runs the site, is both knowledgeable and trustworthy.

Drag the app that won't launch to the ArchiChect app window, and see what it reports.

It's possible that you may be able to get the apps to launch by reinstalling them and then manually removing the quarantine flag. However, you should know that doing so will bypass the security features of macOS, which obviously puts you at some risk if these apps have been tampered with.

Assuming that you are downloading trustworthy apps from trustworthy developers (and not, say, "pirated" or "cracked" versions from somewhere) there probably is not too much risk, but you should be aware of it nevertheless.

To remove the quarantine flag, enter this command in a Terminal.app window:

xattr -r -d com.apple.quarantine 

Make sure there is a space after the word 'quarantine'.

Then drag the app that won't launch to the Terminal window, so you end up with something that looks like this:

xattr -r -d com.apple.quarantine /Applications/Carbon\ Copy\ Cloner.app

(I just randomly picked an app with a space in a filename to use as an example.)

If you get a message about 'Permission Denied' try the same command prefacted with sudo and then be ready to enter your login password (i.e. the password you use to log in to your Mac):

sudo xattr -r -d com.apple.quarantine /Applications/Carbon\ Copy\ Cloner.app
  • yes, I have rebooted the MacBook and actually tried to reinstall the whole operating system and deleted all of the tampered apps, then I reinstalled one of the apps and its not opening still, also the app you recommended to me ("ArchiChect" from The Eclectic Light Company) is installing completely fine, but when I click on the icon it gives me a question mark on the icon. Mar 6, 2021 at 20:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .