1

The printer (HP OfficeJet Pro 8600 (N911g)) stopped working after upgrading the printer driver as per 'HP Easy Start'.

Every print job now times out and all there is to see in the Print Queue application is the message "Printing – Filter failed".

The logs in /var/log/cups show no indication of anything wrong.

The log System Report shows that 'Inkjet3' crashed. (/Library/Printers/hp/cups/Inkjet3.driver/Contents/MacOS/Inkjet3)

Termination Reason:    DYLD, [0x4] Symbol missing

Dyld Error Message:
 Symbol not found: _cupsRasterOpen
 Referenced from: /Library/Printers/hp/cups/Inkjet3.driver/Contents/MacOS/Inkjet3
 Expected in: /usr/lib/libcups.2.dylib

Printer is connected via USB.

Drivers I tried amonng others from HP were:

  • hp-printer-essentials-S-5_14_8_4.pkg

  • hp-printer-essentials-H-5_15_5_5.pkg

Which all seem to report version number '4.5.0' to the system.

The packages available from 'HP Easy Admin' for various macOS versions are all the same down to MacOSX 10.9: "Essential Software 5.10.5.5" 164,4MB

In that state the printer is accepting test-pages from HP utilities and printing them just fine!

Things not resolving the issue:

  • re-installing the latest driver package(s)
  • deleting the printer and re-adding the printer from the PreferencePane
  • resetting the print system (including a reboot before adding printers)

Workaround to get it to print:

  1. resetting the print system
  2. deleting the entire folders /Library/Printers/hp and /Library/Printers/PPDs
  3. adding the printer anew
    only now it automatically downloads old Apple provided drivers?
    Version is identifying as '4.1.1'
    This brings ink to paper.
    (AFAIK among the changes made in a later update by HP was a better ink-economy, so this is financially worth-while to update, if not necessary. The same driver version number is reported if one uses a recent HP forum suggestion to install 'HPPrinterDrivers5.1.dmg' from HP.)

When in that state another attempt to upgrade the drivers is made, it again ends up at the exact same starting point: no printing "Filter failed"/Inkjet3 crashing…

Related questions not resolving this issue:

Looking through other forums, including those from HP, I do not see any solution that allows me printing from macOS 10.12 Sierra to that device with up-to-date drivers.

Printer driver version number as reported to the system 4.1.1 seems to work, version 4.5.0 does not.

How do I get this device to print with the latest working drivers?

4
  • 1
    HP's web interfaces makes it almost impossible to even search for information without an actual model number. – Tetsujin Dec 30 '20 at 17:01
  • It would at least let people have a look around the HP site to see if they find something you missed. Have you tried HP's site, even with a model number, it's a ruddy nightmare (HP owner ;) – Tetsujin Dec 30 '20 at 17:08
  • I see a firmware update as well as the recent easy start (mine updates its own firmware over the 'net rather than through the Mac so I've never tried it that way) support.hp.com/us-en/drivers/selfservice/… – Tetsujin Dec 30 '20 at 17:12
  • 1
    HP's opaque interface seems to make it impossible to even confirm your data… without owning the same printer. No driver details (or any details) on their site other than the version of Easy Start… which I already have, but of course linked to another printer – Tetsujin Dec 30 '20 at 17:21

You must log in to answer this question.

Browse other questions tagged .