I have two macs: one I upgraded to High Sierra without wiping it. All my existing printer drivers function properly.

The second mac I upgraded fresh to High Sierra after a complete wipe. The printer drivers aren't working.

I have a Konica Minolta Magicolor 7540 Grafx II. On the machine with the fresh OS install, the option for duplexing 11x17 is missing. I've tried several different versions of the driver, from various sources, and when I can get it to duplex, it only prints out the left hand side of the page. On one side of the double-sided print, it prints the left hand side of the page, properly positioned on the left hand side of the paper. One the second side of the duplex print, it prints the left hand side of the paper, but it is scooted over to the right, so there is a huge blank space on the left.

Is there a way to transfer all the properly function print drivers from one mac to another? I have tried copying the file from Library> Printers> and Users>Library> Printers. That does indeed give me a second installation of the printer, but the duplexing issue is still there.

Konica has not upgraded their print driver for almost two years, so simply downloading a new one for OS 10.13 isn't possible. The print driver that currently functions properly on my upgraded machine is version 1.7.

I have tried downloading new driers, both of version 1.9 and version 1.7. I have tried copying the Printer settings from the old machine to the new machine. I've tried using the Add Printer function in the System Preferences.

I don't know what else to try. Can anyone assist?

  • 1
    Just a thought and possibly overkill but using the Migration Assistant and transferring EVERYTHING over from the old to the new Mac might do this. Other than that I am not aware of anything that would do what you want. Jan 10, 2018 at 1:25

5 Answers 5


I went through this yesterday and I found a solution -- at least a solution that worked for me.

I have an old Xerox WorkCenter printer for which Xerox no longer produces OS drivers ... but the printer works great. After loads of experimentation, here's what I discovered:

  1. Folders such as /Library/Printers/... seems to be a repository of drivers but these are not drivers that are in use ... they are simply drivers that could be selected to support a printer that needs such a driver.
  2. When you install a printer, it will search the folder for matching drivers.
  3. The driver you select will be copied to /etc/cups/ppd and renamed based on the name you gave your printer. (Note that the top level /etc folder is a symbolic link to /private/etc these days)


My Xerox WorkCenter C2424 was working on another mac and the driver was /etc/cups/ppd/WorkCenter_C2424_93_93_1b_.ppd This name was previously auto-generated by the other mac based on the final octets of the printer's ethernet address.

I copied the above file to the new mac but put it in the /Library/Printers/PPDs/Resources/Contents folder and renamed it back to just Xerox_WorkCenter_C2424.ppd.

I then used the "System Preferences" -> "Printers & Scanners" to install the printer on the new mac. Except rather than letting it auto-select the driver, I chose the "Other..." option which opens a file navigation window and navigated to the /Libary/Printers/PPDs/Contents/Resources folder and selected the driver I copied and renamed from the other mac.

This caused the mac to copy that PPD to the /etc/cups/ppd folder on the new mac and to rename the copy based on the name given in the printer list (you can give it any name you want).

I tested the printer to make sure all features worked and verified this did indeed get the driver to the new mac (the new mac is running Mojave).

I'm not sure if I'll get away with this trick whenever it comes time to upgrade to Catalina ... since Catalina seems to have strict rules on not supporting 32-bit code and these very old drivers are probably not 64-bit drivers.

  • Thanks for this. In my case (HP LaserJet 1020) I was able to simply copy the ppd file (found in /etc/cups/ppd/HP_LaserJet_1020.ppd) from the old machine to the new one, then select the ppd when configuring the printer. This worked where HP's official installer (hpprinterdriver3.1.dmg) failed to install on MacOS Mojave. Dec 11, 2019 at 21:14
  • I wanted this to work! But my 2021 M1 Mac said, "The software for the printer was installed incorrectly. Would you like it to be repaired?" And clicking Repair did not work either.
    – philipkd
    Dec 31, 2021 at 14:33

I know one solution would be to use the Migration Assistant. This has worked for me in the past. I believe you have to migrate "Other files and folders."

Another possibility would be to turn on printer sharing on the Mac with the drivers. Then try to have the Mac, without the drivers, print through the Mac with the drivers. This should install the drivers on the Mac.


I did the following to transfer printer related files from one mac to another (both Intel). My printer is Brother MFC-465CN.

  1. On source Mac:

    cd /etc
    sudo zip -r /tmp/cups.zip cups
    cd /Library
    sudo zip -r /tmp/Printers.zip Printers
  2. Copy above zip files to destination Mac.

  3. On destination Mac (running macOS Monterey):

    cd /etc
    sudo mv cups cups.save
    sudo unzip cups.zip
    cd /Library
    sudo mv Printers Printers.save
    sudo unzip Printers.zip
  4. Add new printer from "System Preferences -> Printers & Scanners":

    1. Select the brother printer from the list.
    2. The "Use" pulldown at the bottom automatically showed "Brother MFC-465CN CUPS".
    3. Click "Add" to add printer.
  5. From "Options & Supplies" for the new printer, viewing "Supply Levels" shows the ink levels correctly (in color), just like the source Mac.

  • 1
    @jaume Thanks for taking the time to reformat. Looks great. Nov 22, 2022 at 7:06

It's possible that the problem is not the driver files themselves, but the settings that they have.

You'll find most of the CUPS (Common Unix Printing System) settings in /etc/cups, though just copying them en masse may be extreme. These include print queues (what MacOS calls "printers"), and their configurations.

You can also access the CUPS settings through a local webpage. First, you have to turn on the web interface. In Terminal, run the following command:

cupsctl WebInterface=yes

Then, in a browser, type the URL: http://localhost:631

(This is a local address on your computer, not a remote connection.)

You can check the settings on one Mac and configure the printers on the other. Click on "Printers" in the header, then click on the print queue, then on the right-hand drop-down menu, choose "Set Default Options".


In my case I have an HP Officejet 8500 working on an older Mac, but was not able to install it on a new M1 Pro.

Just copying the PPD files was not enough. In /Library/Printers of my older mac there was an "hp" folder that was needed as well. Copying it and the PPDs I was then able to install the printer.

(@jaume answer would accomplish this but I have another printer installed and I think replacing the directories would mess with it)

Make sure Rosetta is installed when copying drivers from Intel to Apple Arm Macs.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .