3

My father has a 2019 iMac (with latest version of macOS installed) and about 800GB of free space. The Mac is taking too long to open apps. First, when you click on an app nothing initially happens. After a few seconds, the icon starts bouncing and after minutes, the app launches. After opening and closing the app, it launches quickly. What is the problem?

This is the Activity Monitor while opening Word.

Also I just found out that when the wifi is off every thing is ok and apps run fast.

8
  • 1
    I can only guess it's the Fusion Drive model. I'm afraid that might be the entire problem. I bought my folks an HD-based iMac a couple of years ago - it requires much patience. I should have got them the SSD version.
    – Tetsujin
    Dec 22, 2020 at 14:03
  • Disk space for sure isn't a problem here, disk speed may, or available RAM. Can you add some details?
    – nohillside
    Dec 22, 2020 at 14:05
  • @Tetsujin I don't think the problem is the disk.after the latest software update this happened. Dec 22, 2020 at 14:12
  • @nohillside Sorry I forgot to say an important thing.The problem happened after the latest software update. Dec 22, 2020 at 14:14
  • 1
    Please edit the question to add essential details, they get easily lost in comments. Also, please add a screenshot of Activity Monitory showing the processes/applications using most CPU.
    – nohillside
    Dec 22, 2020 at 14:23

1 Answer 1

0

Is the WiFi configured to assign the Mac a default gateway while simultaneously not actually providing internet access? If so, macOS will assume internet is available but slow, and will continue to make you wait while it Apple's servers whether the app's certificate has been revoked (for security reasons).

When you disable WiFi in macOS it's immediately clear that there's no internet access and suddenly your convenience starts to matter, i.e. quick launches.

You could configure the WiFi network to not have a gateway set, which would probably solve the problem. The DHCP server configuration simply needs to be changed to not set a default gateway.

If you're not able to change the configuration of the DHCP server, you can make a note of the IP address and subnet mask given by the DHCP server (as seen in System Preferences > Network), and then disable DHCP on the Mac and send it to manual instead - entering the same IP address and subnet mask. Preferably you should then remove this particular address from the DHCP pool on the DHCP server so that it is not given to a different computer later.

1
  • Comments are not for extended discussion; this conversation has been moved to chat.
    – nohillside
    Mar 13 at 15:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .