2

I'm not really sure if I'm missing something here, but isn't the idea behind the auto boot and auto shutdown that the mac is ready to work with in the morning when starting to work?

For me that's not quite working.

My Mac starts every morning at 9, I'm in the office at 10 and the Mac is ready to enter my password.

But as soon as I do that, all the auto start apps start opening. Outlook is the biggest problem here, because the software is so insane bad, that it takes ages to start with a big mailbox. I then have to wait something like 10 minutes to actually start working normally. Or even open a website. Not even the settings app is responding for some minutes.

How can I enable to start all those apps already with my auto boot, so I just enter my password, and everything is already running?

I thought this is the idea with autostart?

In no other case than the morning boot my Mac is as slow like this. When everything is running and had it's time to start correctly, it is working super snappy and fast.

My system: macOS Big Sur 11.5.2 iMac 27" 2019 3 GHz 6 Core i5 40 GB Ram

I only have one administrator account on this machine and the guest is disabled. So there is no other choice to select which user should be loaded.

8
  • First I would look at controlling the mailbox: archive, file or delete...
    – Solar Mike
    Commented Oct 15, 2021 at 8:42
  • Fair point, but it's one big exchange mailbox for everybody in our company. I already "archived it down" from 30 GB to 12 GB
    – skarpeta
    Commented Oct 15, 2021 at 8:42
  • 'autostarts' are 'Login Items'… there's a rather unfortunate hint in the title - they'll start at login. I don't know a way round that short of auto-logging in, which would be a security concern in a location you will not be present when it happens.
    – Tetsujin
    Commented Oct 15, 2021 at 9:50
  • Asking why you shut down the machine every night, vs putting it to sleep? Commented Oct 15, 2021 at 17:47
  • @MarcWilson - yup, that would be the 'simplest' fix ;))
    – Tetsujin
    Commented Oct 16, 2021 at 7:43

1 Answer 1

0

I accidentally found this option in the settings by changing my start options. So far it's working as I wanted it.

Go to Users & Groups and select Login Options there you can select a user for automatic login.

Screenshot of settings

4
  • Yup, as in my first comment above. If it's not a security concern, then it will work just fine. :)
    – Tetsujin
    Commented Oct 19, 2021 at 17:37
  • No, not really. I still had to enter my password to login.
    – skarpeta
    Commented Oct 19, 2021 at 18:20
  • 1
    You did - but now it will start up & login automatically… before you get to work. By the time you get there it may have had time to lock again - during which time those processes would continue, but there would be a period it's unlocked & unattended. That was my initial concern. I do it myself here at home, because I don't consider it so much of a risk.
    – Tetsujin
    Commented Oct 19, 2021 at 18:34
  • Good point. Didn't thought about it that way. But no, that's no concern because everything is stored on our server anyway.
    – skarpeta
    Commented Oct 20, 2021 at 13:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .