9

Whenever I open Google Chrome (including Chromium and Canary) on my Mac the location is set to off. So I must go to Preferences -> Security & Privacy -> Privacy -> Location Services and set Canary's location setting on.

However, I'm not sure why Chrome's location setting is set to off whenever I quit the app. How can I make the location setting permanent?

I lock the key icon on the privacy setting once I checked on the Chrome's location setting but it didn't work... I use macOS 11.0.1 (updated to 11.2 now) and found this is true on multiple macs.


UPDATE

I found out that this problem happens on all Chrome variants. Also, this even happened while I'm running the app.

3
  • I have the same issue with (non-Canary) Chrome 87.0.4280.141 on macOS High Sierra 10.13.6. (Presumably @Blaszard is not actually on OS X Cheeta 10.0!)
    – cpcallen
    Feb 5 at 22:35
  • @cpcallen Aha, fixed. I also found the issue occurs on Chrome too.
    – Blaszard
    Feb 6 at 4:37
  • Having the same problem and it drives my crazy -- I have a feeling this is a feature and not a bug. I assume it has to do with the tighter privacy controls and new version requiring authorization again. Chrome updates automatically and often that must unset the allowance. Apple has just been on the warpath lately cutting other companies down under the guise of "privacy!".
    – Brent
    Apr 10 at 15:12
1

Not a solution, but perhaps a path to one....

Many people (including me) have this problem. In another forum, a user (Sizmo_68) inspired me to wonder:

What if the abhorrent security preferences in macOS are remembering the version number (or similar) of each app that has location (or other preferences) enabled? Then, when the app gets updated...poof, new version, and ... it no longer matches what's in the security database, so: no longer enabled.

If that's the case, we're out of luck until Apple admits the problem and fixes it.

As one other user pointed out, it's clearly a macOS problem (not a Chrome problem), because by implementation apps can't change the security preferences :)

1

This is tracked here (I think.) Sounds like it's fixed and hopefully will be corrected in a coming chrome version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .