1

I've always found it difficult to get pictures out of my own iPhone, yet still doable with enough work. But my wife's iPhone is another animal. I am at a total loss with this iPhone 7+ (iOS 13.3.1), I feel like I've tried virtually everything. Here's what I want from this iPhone:

  1. All files in their original qualities.
  2. All metadata, especially timestamps that tell you when the picture was taken.
  3. All original internal image names (IMG_0678.JPG, etc.) used by the iPhone, not goofy new ones made up by Windows (001.JPG).

Here's what I've tried to get these darn jpegs out of this aluminum jail cell. In all of these cases, when relevant, I have 'trusted this computer' on the iPhone.

In MacOS 10.14:

  1. iTunes (up-to-date): iTunes could not connect to this iPhone. Could not save the pairing record.

  2. Airdrop from iPhone to Macbook: Freezes on the iPhone whenever I try to export an image with airdrop. Also in the past, if I remember correctly, the Macbook would recognise the iPhone but the iPhone would not recognise the computer (or maybe it was the other way around).

  3. Photos app: Device is recognised, but no photos are found.

  4. Image Capture app: Device is recognised, but no photos are found.

  5. Third party app, iFunbox: Device pairing required. Please launch iTunes and pair your iOS device with this Mac.

I have not tried iCloud, because I have more than 200GB of pictures to transfer and only 5GB of space on iCloud.

In Windows 7:

  1. Windows explorer shows the iPhone (sometimes), but its content usually appears empty. When it does not appear empty, it shows the DCIM folder, which itself usually appears empty. Once it did not appear empty and the pictures were there, but when I repeatedly tried copying the contents of one of the 26 1XXAPPLE folders (1 folder is about 1300 files), the copy process randomly stopped with no error message after having successfully copied 4 files. The 'copying' progress box simply vanished and copying stopped. On inspection of one of the photos that was ''successfully'' copied, I notice that the original image on the iPhone had a size of 2.88MB, whereas the copy I had made on Windows had a size of 26.4KB.

  2. Right click iPhone in Windows Explorer and click 'Import Pictures and Videos': After copying about 5 photos it outputs The following error occurred while importing IMG_0688.MOV: The exact error is unknown. Make a note of this error code, which might be useful if you seek additional help to resolve this problem: 80042007. What do you want to do? (a) Try again (b) Skip this file (c) Skip all files with errors ''Try again'' leads to the same problem. ''Skip this file'' leads to one successful file copied and then the same problem with IMG_0693.JPG. ''Skip this file'' again leads to the same problem on the next photo. ''Skip all files with errors'' skips most (about two thirds of) files. Also this approach gives the files imported into Windows new names (001.JPG, 002.JPG, instead of IMG_0692.JPG, IMG_0693.JPG). Not only is this confusing, but it's also annoying because with the IMG_XXX.JPG system, only photos taken on this iPhone had an IMG_XXX.JPG name, whereas with the 001.JPG system all JPGs including random photos received from contacts on whatsapp get a 001.JPG style name.

  3. iTunes (up-to-date): Produces error message: iTunes cannot read the contents of the iPhone 'iPhone of X'. Go to the Summary tab in iPhone preferences and click Restore to restore this iPhone to factory settings. Would erase the photos, so not acceptable.

  4. Third party software, attempt 1 -- Some freeware on my wife's computer a while back: This has allowed me to export pictures, but it failed to export their metadata (time taken, etc.), making the exports not really acceptable.

  5. Third party software, attempt 2 -- Nero Kwik Media: Requesting to discover files on the iPhone crashes the program.

In Ubuntu 18.04:

  1. Usually an iPhone's filesystem is directly accessible in the file manager. Instead, when I plug in the phone I get a dialog box: Unable to mount X's iPhone - Unhandled Lockdown error (-3).

What's wrong with this iPhone? Is it a regional problem? We bought it last year refurbished from Amazon UK when we were living in the UK and we now live in Canada. It's hard for me to believe that all of these problems are independent. Apart from this problem, the iPhone works well. There are about 26,500 photos and 3300 videos to export.

Up next, 12. Send myself 2650 emails for the photos and forget about the videos?

6
  • Could you try updating iOS on the phone and try again? - 13.3.1 is a relatively old release (i.e. you're 8-9 releases behind) - as you seem to be experiencing bugs or problems, it might be a good idea to update. – jksoegaard Nov 11 '20 at 4:57
  • Where are the pictures? Only those in Camera Roll are 'eligible' for transfer over Photos or Image Capture. Any that were synced-in from other sources should still be accessible from those other sources. – Tetsujin Nov 11 '20 at 8:03
  • Consider buying enough iCloud space, at least temporarily. – lhf Nov 11 '20 at 9:11
  • @jksoegaard I'd like to backup the photos and then update, if possible – Pertinax Nov 12 '20 at 3:23
  • @Tetsujin I just want the pictures in the camera roll, they are all there. Some pictures received from contacts in whatsapp are in the camera roll too though – Pertinax Nov 12 '20 at 3:23
1

In cases like this, I've found iExplorer the only way to 'crack the aluminum jail cell', so to speak. It has macOS and Windows versions of the app, and a free trial version to experiment with before purchase. It can also open iTunes backups of the device on your Mac/Windows device as well. If the backup is encrypted, you will need the password.

Disclaimer: I'm a very satisfied customer of Macroplant LLC, and have no financial or other ties with the organization.

1
  • I got this software and it does work for most files! There seems to be some large videos (12GB) that it does not find though, is there a work around? – Pertinax Nov 12 '20 at 3:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .