2

Last week, my Mac running 10.15.7 became slow: starting apps took a long time. This is the case for both UI and console programms. After some analysis, I found out that

  • In most cases, program startup is delayed by exactly 1 minute
  • Most preinstalled apps (Maps, Preview, ...) start fast, as usual

What I have tried so far

  • Check if there are resource hungry background proceses (there are none; CPU and IO are low)
  • Reset NVRAM+PRAM (option+command+P+R on boot)
  • Check Traps log; looks OK

It seems that on console, most programs at /usr/local/bin are affected, while most /usr/bin/ programs are not.

The mysterious delays seem to be interrelated: when I run sleep 20; time git and time git simultaneously, time says

 real   0m38.796s
 user   0m0.003s
 sys    0m0.005s

for the 1st call and

 real   1m0.537s
 user   0m0.003s
 sys    0m0.013s

for the 2nd.

Any ideas?

4
  • which version of macOS are you running? – nohillside Oct 28 '20 at 7:32
  • @nohillside 10.15.7 on a MacBook Pro – Christoph Walesch Oct 28 '20 at 7:53
  • 2
    I wonder if this is related to stapled notarizations and possible timeouts to check for revoked certificates. Excellent details to try and reproduce this. – bmike Oct 28 '20 at 8:36
  • I just tested this by monitoring the logging of Xprotect and issuing some git commands and it appears, Xprotect was never "called home" to check it. Also, git may not be the best example especially if you're cloning/syncing/merging across the network/Internet. There's inherent latency from any point in between A and B that could cause this delay. – Allan Oct 29 '20 at 16:55

You must log in to answer this question.

Browse other questions tagged .