1

I am new to the MacOS, and I have started using iTerm2, and I want to make the changes to my UI permanent, but I am unable to do so.

When I "right-click" in the iTerm window and go to Edit Session... → Preferences → Text → Cursor → Vertical Bar , my current instance of iTerm does what I want it to.

However, when I shut it down and start another window some time later, it reverts back to its old settings. How do I make these settings permanent so I don't have to keep repeating the above process?

  • Nope, your default shell is ZSH. "Terminal" refers to the app that allows you to access the shell. In your case iterm.app. Run that displayed command to convert your bash defaults to zsh like the prompt says. What does it do, exactly? Try that URL. – Steve Chambers Aug 22 at 20:55
  • I made a heavy edit by removing the second question - it's not that it's a bad one, it's just that this site works best as a 1-to-1 - one question per question. Also, that particular question has likely already been answered. See: apple.stackexchange.com/search?q=+bash+default+zsh. If not there, go ahead and ask a new one! – Allan Aug 22 at 20:56
2

"Edit Session" is exactly that - it edits that particular session.

If you want to make it permanent, you have to make the change in your profile. Go to Preferences → Profiles → Default Profile → Text

enter image description here

Obviously, you select the profile you want that change made to - I'm showing the Default Profile for this example.

| improve this answer | |
  • Thanks for your input! how do I go to Preferences in profile? I looked up Preferences on spotlight, but couldnt find it there, and right clicking terminal itself doesnt lead me to it... I am using iTerm2, sorry I did not include that in the original question... – megamence Aug 22 at 21:41
  • Preferences for this and any application can be accessed by pressing Cmd-, (that's Command and Comma) or by going to the menu bar at the top of the screen, selecting "iTerm2" and then "Preferences" – Allan Aug 22 at 21:50
  • brain expansion moment. thank you! – megamence Aug 22 at 21:51
  • No worries at all! – Allan Aug 22 at 21:51
0

Go to Preferences under the iTerm menu item and click on it. It brings up a small pane shown here.

w

Click on Profiles and that brings up a new larger pane shown here.

enter image description here

Give your profile a name and then set all the parameters you want. Select your profile name in left side of the panel and then close the pane. Now when you open iTerm it should use the profile you defined.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .