I have 2 external monitors to my 2017 Macbook Pro v.10.15.6. Sometimes it slows -- the mouse lags badly.

I installed gfxCardStatus and sometimes the menu choice changes from Dynamic switching to Discrete only. It seems that the mouse starts lagging just when that happens.

  • Is it possible that "Discrete only" slows the computer?
  • Why does this switch automatically?
  • How can I keep it on "Dynamic switching"? The Macbook is always plugged in so power consumption is not a concern.

(This relates to my earlier question, in which "Automatic graphics switching" under Energy saver was getting automatically enabled. I wrote a script to keep it disabled, for better performance with more power consumption. It seems that that is a different setting from this "Dynamic switching" in gfxCard Status since Dynamic switching seems to increase performance.)


  • Presumably this is a 2017 MacBook Pro? The whole point of Discrete GPUs is to offer better performance than the Integrated unit, so it shouldn't slow it down. However, discrete GPUs seem to be the cause of lots of problems.
    – benwiggy
    Jul 19, 2020 at 10:10
  • Thank you, yes, 2017. I edited the text to clarify. What you say about performance makes sense. Is there a way to force my Mac to stay on "Dynamic Switching"?
    – Joshua Fox
    Jul 19, 2020 at 11:22
  • The person to ask is the author of gfxcardstatus.
    – benwiggy
    Jul 19, 2020 at 13:18

1 Answer 1


The author of gfxCardStatus answered here.

If your goal is better performance regardless of power consumption, then the solution is really simple: quit gfxCardStatus, delete it, and disable automatic graphics switching in System Preferences > Energy Saver. That will cause the discrete GPU to be used all the time.

When gfxCardStatus is running, it manages the automatic graphics switching setting for you. Dynamic Switching is equivalent to having the automatic graphics switching checkbox checked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .