3

My MBP (mid 2010) is suffering from the Intermittent black screen or loss of video issue. More specifically, it may happen that when switching from dedicated to integrated graphics, the screen goes black. Only a reboot helps in this case.

So I tried to disable the automatic graphics switching (via "System Preferences" -> "Energy Saver"). Nevertheless, graphics switching still occurs; I can't say when or what's causing that, though. It always appears to be the case after waking up from sleep / suspend-to-ram. As per gfxCardStatus, "Dynamic Switching" is enabled then, which is exactly what I seeked to prevent via the systems preferences.

Is there a way to permanently disable the dynamic graphics switching and only work with the discrete graphics? I wouldn't mind the shortened battery lifetime if that helped to prevent the black screen issue to occur.

  • gfxCardStatus should be able to do that, check the official page on switching edit: oh, you mean that on wakeup gfxCardStatus automatically sets itself to dynamic? – listik Dec 1 '14 at 11:50
  • I'm not sure whether it's gfxCardStatus itself which sets it back to dynamic switching or something else. But using gfxCardStatus I can see that dynamic switching is enabled after wake-up. I'm looking for a way to prevent this from happening. – Gunnar Dec 1 '14 at 14:54
  • I don't have a compatible computer to do tests right now, but I think gfxCardStatus supports command-line commands. Can you try and see if executing this in the terminal changes modes? <route to app>/gfxCardStatus.app/Contents/MacOS/gfxCardStatus --discrete Other available commands are --dynamic and --integrated. If that works, a workaround solution would be to automatically launch that command on wakeup. – listik Dec 2 '14 at 16:00
  • That's a good idea. Can you post it as answer? Then I'll award the bounty to you. Thanks! – Gunnar Dec 3 '14 at 21:57
1

Can you try and see if executing this in the terminal changes modes?

<route to app>/gfxCardStatus.app/Contents/MacOS/gfxCardStatus --discrete

Other available commands are --dynamic and --integrated. If that works, a workaround solution would be to automatically launch that command on wakeup.

0

now i don't know when you purchased your computer, but apple offers 3 years extended warranty for your computer, if you can, make an appointment to a local appplestore, and try to get your graphic card replaced for free!

  • It's mentioned in the link provided by the OP. – Mateusz Szlosek Dec 1 '14 at 12:57
  • Unfortunately it's older than three years, so I'm not eligible for the free replacement. – Gunnar Dec 1 '14 at 14:52
  • have you tried it tho? apple is known for goodwill – Macmaniman Dec 2 '14 at 8:50

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .