macOS Catalina Version 10.15.5

I have downloaded XQuartz from following page (https://www.xquartz.org/). The application installed and shown on the Utilities folder. When I open it, it is shown a second on the docker and always gone away (quits itself). It does not show up on the running applications, so I crashes due to some reason.

enter image description here

I don't know how can I fix this issue, since I am not able to open the application. Is there any way can I fix this issue?

  • What has changed on your system since apple.stackexchange.com/questions/395682/… (there it seemed to have worked)?
    – nohillside
    Jul 16, 2020 at 11:35
  • Actually it was working yesterday and nothing is changed. I think I have clicked Hide for XQuartz on the Dock bar and hide option did not show up again. After multiple reboots XQuartz shows up on the Dock. I am not sure could it be the reason? @nohillside
    – alper
    Jul 16, 2020 at 11:47
  • Hard to say what went wrong afterwards...
    – nohillside
    Jul 16, 2020 at 11:55
  • I cannot find its log files. Since the app does not open I cannot access its preferences. When I open it it shows up on the Force Quit Applications but removed also after a second. Maybe if I can start it from terminal (without a gui) I can find some clues
    – alper
    Jul 16, 2020 at 11:58
  • /Applications/Utilities/XQuartz.app/Contents/MacOS/X11.bin seems like this open the program but it dos not open within Dock or finder
    – alper
    Jul 16, 2020 at 13:21

1 Answer 1


I was able to solve it by running from the Terminal.

run_Xquartz() {
  [ $(ps aux | grep -E '[X]quartz' | wc -l) -gt 0 ] && echo 'Xquartz is already running' \
  || nohup /Applications/Utilities/XQuartz.app/Contents/MacOS/X11.bin > /dev/null 2>&1 &

$ run_Xquartz
  • If Xquartz is already running on the background it prints Xquartz is already running.
  • If Xquartz is not running on the background it runs it on the background using nohup.

=> When Xquartz starts running on the dock you will see it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .