1

getting a bit desperate here after trying everything I could find/think of — I'll just come out and say that I have a weak back ground in unix systems.

I use XQuartz 2.7.11 to connect to a RedHat server run by our group to use some software packages. I am able to login and connect to the server normally but when I try to launch an application, terminal opens XQuartz but it cannot generate any windows. I am having the same issue with another simulation code that is installed locally but uses XQuartz to generate some UI elements — the point of saying this is that I don't believe it is any issue with connecting to the server.

Furthermore, if I open XQuartz normally and try to open the XQuartz terminal nothing happens. Under XQuartz>Applications> there are also "xman" and "xlogo" options that don't do anything when clicked. Previously I remember clicking "xlogo" would open up a small icon of XQuartz in a window. So this seems like something is preventing XQuartz from opening any kind of desktop windows.

One last note, if I try to run a terminal command that normally opens XQuartz, then XQuartz launches but doesn't generate any windows like previously mentioned but also I cannot close XQuartz. Quitting XQuartz just causes it to restart a second later (likewise for force quit). The only way to keep it from reopening is to log out. This makes it seem to me like the original command that uses the X11 window server is continually trying to open it without success causing XQuartz to come up — even if I close terminal.

I noticed this issue the first time I installed Xcode and Python IDLE. I have since removed and reinstalled every combination of XQuartz and Xcode.

Looking for any suggestions short of reinstalling macOS.

  • 1
    The tricky part is to figure out where the issue is. Can you try the following: Create a new user on the Mac, log into this account and try to run XQuartz there (just with local commands like xterm first). – nohillside May 3 '18 at 18:15
  • 1
    Thanks for the reply! I created a new user and verified that the behavior is the same. Cannot open xterm and cannot open the windows server after attempting to connect to the server and enable X11 forwarding. Also tried to reinstall XQuartz from the new user profile for good measure. – sergiyr May 3 '18 at 18:49
1

Reinstalling macOS from the online recovery option (Command-Option-R at startup) fixed the issue. All my files, programs and settings remained as before. I've tried many things but seems like this was the way to go from the start.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .