15

I am trying to maximize my Terminal window so that it goes from edge to edge. I do not want to take it full-screen.

However, I am observing that I am unable to do so and despite by best effort, there's a tiny gap that remains at the bottom of the window. The same can be seen in the screenshot below:

terminal

I do not encounter this behvior with other macOS apps, just the Terminal app. Is this by design? or could this be a possible bug with the app?

2
  • Why not use full screen here what benefit do you get doing this? – mmmmmm Jul 13 '20 at 9:52
  • 2
    @mmmmmm I choose not to use full screen because that way you have one more screen to switch when you want to change screen. – zyy Jul 13 '20 at 13:49
25

Terminal windows are always sized to show full text lines (you can check this by resizing the window manually to see that it resizes in steps), so for example if your text height in Terminal is 10pt and your screen height is 1275pt there will be a 5pt gap at the bottom (numbers not real and ignoring menu bar, window title etc, just to show the principle).

3
  • A notable quirk is that Terminal does launch properly at first. In my experience, it only reverts to the behavior OP describes after new tabs are opened and closed. – Arnon Jul 13 '20 at 22:11
  • 3
    A possible workaround is using iTerm2 instead of Terminal. iTerm's windows can be maximized fully; they insert in-window padding instead of not letting you enlarge the window further. – Peter W. Jul 14 '20 at 12:40
  • 1
    @Arnon thats because tabs take up pixels; your font settings pre-tab are probably just right, but the extra tab UI puts it off – D. Ben Knoble Jul 14 '20 at 20:55
1

As @nohillside said in his answer, the font settings has to match perfectly a line in order to have a real fullscreen.

So you can tweak Font size and Line Spacing in order to find a "line perfect" setup (tips: put a white window behind your terminal to easily set it up)

I tried many fixed width fonts (SF Mono, Monaco, Menlo, PT Mono), and here a setup that worked for me:

  • macOS: 10.15.7
  • Screen: 1920x1080 (16/9)
  • Tab Bar: Always shown (View > Show Tab Bar)
  • Font: Menlo Regular
  • Font Size: 14
  • Character Spacing: 1.046
  • Line Spacing: 1

Note that Character Spacing does not impact the height, it is just more confortable to me.

Because my Macbook is 16/10 I still have a slight gap on it, but it is perfect on my external monitors.

If you have any other setup that works for you feel free to comment on this post

0

Something that worked for me was opening Terminal settings (CMD+,), going to the 'Window' tab of the current profile, and setting the row count to the number of rows that resulted in the terminal window closing that gap.

Note that this doesn't necessarily increase the amount of functional real estate in your terminal window. If there's a gap in the first place it's likely because the height of your screen and your font settings do not accomodate an integer number of rows. This will not change by changing the row count. Your terminal will still display the same number of rows. It's just that now that gap will be converted from a gap between your terminal window and the bottom of your desktop to a gap between the last row in your terminal and the bottom of your terminal window.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .