I have an Late 2012 27" iMac (iMac13,2) and somehow when looking in system report for the Thunderbolt ports say "no hardware was found.”

I have tried:

  • Endless searching to find a solution
  • Resetting SMC and NVRAM
  • Updating OS to High Sierra
    • Clean Install, deleting HD and installing High Sierra
    • Clean Install, with 2nd level secure disk delete in hopes to delete firmware
  • Updating Thunderbolt firmware 1.0, 1.1, and 1.2 to no avail
  • Tried to create a bootable installer of Yosemite to trick the machine into letting me "downgrade" firmware to v1.0 or v1.1. I’m almost positive that it's a firmware issue as the system does not see any Thunderbolt firmware.

This system was used as the heart of an audio editing project studio and is now completely non-functional as the two high-end Thunderbolt audio interfaces used to get audio in and out of this iMac are no longer functional.

What can I do to fix the Thunderbolt ports?

1 Answer 1


Hardware not found

When it comes to hardware, there are two “conditions”

  • Detected
  • Functional

Hardware can be detected and non-functional, but it is impossible for it to be functional without being detected.

When something is detected, the system says “I found this piece of hardware. It’s identified by these numbers at such-and-such and address.” That’s a very simplistic description of what happens but it encapsulates the concept.

Hardware is functional when a driver(kext) is loaded and the device can be used by the system to do whatever it’s designed to do (i.e. webcam displays pictures and captures sound)

Your Thunderbolt subsystem has failed

Now, if a previously functional device suddenly is no longer detected, the device has failed. It could be the Thunderbolt controller or the associated circuitry, but in the end, it has failed to the point where the system doesn’t see it.

I’m almost positive that it's a firmware issue as per the system does not see any thunderbolt firmware.

Unlikely. Even if the firmware was corrupted, your system would report an “unknown device” because something would be there, it just can’t identify what it is. Upgrading/downgrading firmware is not going to work if it can’t find the device which to apply the update.


The very first thing that should be invoked long before you reinstall the or do any sort of firmware patching is to run Apple Hardware Test (Hold D while booting). An OS reinstall should be done last. In fact, you should install macOS onto an external drive and boot off of that instead of wiping the drive. Why? If there is any sort of forensic evidence of the failure, it gets erased with the new install.

Resetting the NVRAM and SMC are usually fruitless because they’re unrelated, but it can’t harm anything. Before wiping the hard drive and reinstalling the OS, try Safe Mode or Recovery Mode. These are clean, versions of macOS (Recovery, especially) that have only the native drivers. If the hardware device can’t be seen here, it’s definitely a hardware failure.

Bottom line

It’s got to go in for service or you need to replace the unit.

  • First off, let me thank you for your reply, it is much appreciated. - I did run the Apple diagnostics on the machine in which it returned a memory error. after removing the 16gb that was added to the original 8gb that shipped with the iMac, the memory error was no longer registering and the hardware diagnostics passed. -My Firmware suspicion is per - The hardware not recognized can be powered and work fine on another computer. -- Also, the other peripheral connection points such as USB also show their firmware in system report, when nothing is connected. There have been numerous Jun 7, 2020 at 4:41
  • reports of this issue on forums with no found solution other than the Yosemite trick that didn't work for me. I have yet to try to install Mojave or Catalina to see if they come with a firmware fix. Also, the MacOS installs I've done have been clean and with the use of bootable installers on usb drive, preluded by a clean delete of the system hard drive in attempt to delete any attached firmware / software for the thunderbolt ports. The USB ports work just fine and show up in system report when not connected to anything with their proper firmware version displayed. Jun 7, 2020 at 4:47
  • I have yet to try Safe Mode or Recovery mode neither the two latest OS installs and I will attempt these later today. Thank you so much for the responses but I really think it must be a firmware update that was caused by applying a firmware update that apple intended v1.2 for it's thunderbolt displays but got applied to the iMac and thus bricked the thunderbolt ports overwriting their firmware so the machine can not detect them this is the problem I'm relatively confident that I need help with. One user on youtube had the same exact issue and was able to boot on a Yosemite disk and trick the Jun 7, 2020 at 4:50
  • OS into installing a previous firmware update that then solved the problem, while still running Sierra. Unfortunately, a disk erase OS HD, followed by a clean install of High Sierra, followed by his tutorial with a separate bootable drive with Yosemite, resulted in the v1.0 and v1.1 firmware update installers unable to install per the Mac OS stating that the updates did not apply to this machine....... Jun 7, 2020 at 4:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .