3

I have an iMac 18,2 with the current operating macOS Sierra. Now I want to clean install the existing OS using macOS High Sierra v10.13.6, I went to the recovery mode, connect to wifi and click on Reinstall but the issue that I encountered is whenever I try to install it I get the following error:

An error occurred while preparing the installation. Try running this application again (I tried this more than 5 times and still get the same error).

Screenshot of the above error:

install error

I spent a couple of hours trying to find a solution and one of them said that I need to delete the Macintosh partition or check on the partition disk for error first. So, I went ahead and clicked First Aid scan the disk for error for the Macintosh HD partition but it also failed with an internal error. When I try to delete the partition and always get the following error message:

Erasing "Macintosh HD" and Creating "Macintosh HD" Erase process has failed. Click Done to continue. When I click show Details: Erasing APFS Volume File Content An internal error has occurred. Operation failed

Screenshot of the above error:

partition remove error

Is there a way to completely remove the partition, and do a clean install? I also was not able to unmount the partition.

I was also able to create a USB installer for this and the MacOS Sierra can still be used without issue. Is there a complete step on how can I resolve this issue of being unable to erase the partition? My aim is to be able to install MacOS High Sierra in clean mode. I don't want any backups left. Thank you...

PS: this imac originally came with MacOS High Sierra but it was mistakenly downgraded to Sieera

2
  • If you want to erase only the partition, you should erase the apfs container (View > Show all devices in Disk Utility), not just the volume within.
    – Redarm
    Dec 7, 2022 at 16:34
  • Ohh, I think I missed that menu. It was missing before. I'll check (once the drive is ready)
    – MaXi32
    Dec 7, 2022 at 16:36

1 Answer 1

3

High Sierra was the first 'transition' OS to support APFS.
Because it was always expected to be updating from Sierra, it doesn't want to see an APFS drive itself. It wants to see an HFS+ drive it can itself convert as part of the installation process.

You presumably have all important data already backed up to another location, so you should be able to use Disk Utility to re-format to Mac OS Extended (Journaled), GUID Partition Map.
This should then let the High Sierra installation proceed.

4
  • I did try to format it to Mac OS Extended (Journaled) but there was not option to select GUID partition map. So, the format didn't go through.
    – MaXi32
    Dec 7, 2022 at 16:35
  • Erase the entire disk, don't format the partition. You only get the option at disk level [as it affects the entire disk, of course]. idk when Apple started doing this, but look at the View menu - there may be options to 'show volumes' or show devices - you need to see [& Erase, not format] devices.
    – Tetsujin
    Dec 7, 2022 at 16:49
  • 3
    I believe High Sierra can be installed to volumes in an APFS container when the container is created using High Sierra's version of the Disk Utility. Dec 7, 2022 at 21:41
  • @DavidAnderson - interesting. I didn't know that. What I did just spot though is that the installer picture above is actually Sierra not High Sierra… making the need for HFS+ more certain;))
    – Tetsujin
    Dec 8, 2022 at 7:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .