2

I run an MBP 13-inch Mid-2012, with an SSD I installed and running OS X Catalina 10.15.4

I notice that sometimes when it goes to sleep it shuts down if it isn't plugged in (I have to hit the power up when I use it again) and today it was plugged in, but when I touched he keyboard instead of waking from sleep as usual it was at the login screen and was telling me the computer shut down because of a problem.

This was the report the computer generated:

Sleep Wake failure in EFI

Failure code:: 0xffffffff 0x0000001f

Please IGNORE the below stackshot

================================================================
Date/Time:        2020-05-13 02:45:21 -0400
OS Version:       ??? ??? (Build ???)
Architecture:     x86_64
Report Version:   29

Data Source:      Stackshots
Shared Cache:     0x2f3e000 F04A453C-3C9D-3D12-B86E-C514F0DE0B14

Event:            Sleep Wake Failure
Duration:         0.00s
Steps:            1

Time Awake Since Boot: 12s



Process:          swd [376]
Architecture:     x86_64
Footprint:        380 KB
Start time:       2020-05-13 02:45:21 -0400
End time:         2020-05-13 02:45:21 -0400
Num samples:      1 (1)

  Thread 0x84f    1 sample (1)    priority 4 (base 4)
  <thread QoS background (requested background), thread darwinbg, process darwinbg, IO tier 2>
  1  start + 1 (libdyld.dylib + 109769) [0x7fff6a16ecc9] 1
    1  ??? [0x10ccb6454] 1
      1  ??? [0x10ccb61dd] 1
        1  __stack_snapshot_with_config + 10 (libsystem_kernel.dylib + 135862) [0x7fff6a2d02b6] 1
         *1  ??? [0xffffff80002c8206] 1
           *1  ??? [0xffffff80009875f7] 1
             *1  ??? [0xffffff80008a0001] 1
               *1  ??? [0xffffff80002eb9e7] (running) 1

  Binary Images:
        0x7fff6a154000 -   
0x7fff6a18afff  libdyld.dylib (750.5)               
<D2A07EF5-A64B-3692-BE13-89DAA2EC5E80>  /usr/lib/system/libdyld.dylib
0x7fff6a2af000 -     
0x7fff6a2dbfff  libsystem_kernel.dylib (6153.101.6) <E76440E1-D1E8-3D9A-8B47-D01F554FF1C4>  /usr/lib/system/libsystem_kernel.dylib

Model: MacBookPro9,2, BootROM 231.0.0.0.0, 2 processors, Dual-Core Intel Core i5, 2.5 GHz, 8 GB, SMC 2.2f44

Graphics: kHW_IntelHD4000Item, Intel HD Graphics 4000, spdisplays_builtin

Memory Module: BANK 0/DIMM0, 4 GB, DDR3, 1600 MHz, 0x802C, 0x384B54463531323634485A2D314736453220

Memory Module: BANK 1/DIMM0, 4 GB, DDR3, 1600 MHz, 0x802C, 0x384B54463531323634485A2D314736453220

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xF5), Broadcom BCM43xx 1.0 (7.21.190.33 AirPortDriverBrcm4360-1601.1)

Bluetooth: Version 7.0.4f6, 3 services, 18 devices, 1 incoming serial ports

Network Service: Wi-Fi, AirPort, en1

Serial ATA Device: WDC  WDS100T2B0A-00SM50, 1 TB

Serial ATA Device: HL-DT-ST DVDRW  GS41N

USB Device: USB 2.0 Bus

USB Device: Hub

USB Device: Hub

USB Device: Apple Internal Keyboard / Trackpad

USB Device: IR Receiver

USB Device: BRCM20702 Hub

USB Device: Bluetooth USB Host Controller

USB Device: USB 2.0 Bus

USB Device: Hub

USB Device: FaceTime HD Camera (Built-in)

USB Device: USB 3.0 Bus

Thunderbolt Bus: MacBook Pro, Apple Inc., 25.1

Any ideas as to what's going on? This seemed to only start happening recently. Should I reset the SMC? NVRAM?

I did as @Allan suggested in comments and got this:

Timestamp               Ty Process[PID:TID]
2020-05-14 04:45:06.022 Df kernel[0:a9] (AppleSMC) Previous shutdown cause: -104

So does this mean reset SMC?

ETA II : Reset SMC, problem seems to be solved, though my FileVault was disabled.

4
  • Let's find out what error code was generated for the shutdown. In Terminal, issue the command log show --predicate '(process = "kernel") && (eventMessage CONTAINS "shutdown cause")' --last 48h --style compact and edit the question with the results. That only goes back the last 48 hours so, if, it's longer than that change the 48 to a value more appropriate.
    – Allan
    May 13, 2020 at 16:41
  • Allan - this is what I got Timestamp Ty Process[PID:TID] 2020-05-14 04:45:06.022 Df kernel[0:a9] (AppleSMC) Previous shutdown cause: -104
    – Jesse
    May 14, 2020 at 10:42
  • Negative numbers are hardware related. Reset the SMC. If that doesn’t fix, you need to take it in for service.
    – Allan
    May 15, 2020 at 4:26
  • I reset the SMC, that seemed to solve it. My fileVault was disabled, tho.
    – Jesse
    May 15, 2020 at 11:30

2 Answers 2

1

This is usually a problem with the 'deep sleep' / hibernation mode macOS uses. Basically, when you close the lid your Mac goes in standby mode. After some time has passed, your Mac goes into hibernation mode to save more battery. As it seems, your Mac isn't properly able to either go into hibernation mode, or recover from hibernation mode, causing your OS to simply reboot.

Resetting SMC sometimes fixes the issue, but there's a lot unclear about these errors. Some users have stated that resetting SMC works, but only if FileVault is disabled.

0

I had the same problem start after I updated to Catalina 10.15.4. After some research I turned off POWER NAP from System Pref/Energy Saver and the problem went away.

MBP 16 2019

2
  • I don't have a power nap setting, but my mbp is a 2012 model ?
    – Jesse
    May 15, 2020 at 2:04
  • Power Nap is an integral feature.. If you have to turn it off to fix something else, you have a bigger problem and this isn’t fixing it.
    – Allan
    May 15, 2020 at 4:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .