0

So, assume I have 4-5 instances of an app running on different monitors (in this case, using DisplayLink Manager). Some times, some of the instances cannot be switched to anymore. When I right-click on the Icon in the dock I will see all instances, but with some of them nothing happens when selecting. Even in Mission Control the app instances are shown on the right monitor with the right state, but some of them just cannot be selected (they animate to kind of full screen and then disappear).

I am not sure what causes this behavior, maybe disconnecting the Mac from the dock and then reconnecting. Might the window(s) land off-screen?

In Windows this kind of stuff sometimes happened in multi-screen environments and you could do some trick to get the focus on the app and move it with the keyboard / mouse. In Mac I don't seem to find a way to recover these apps without killing them.

In my particular case killing the app has also the disadvantage that I only see one process in the Activity monitor, so I would have to kill all my running instances every time this happens.

Is this a bug with Mac / DisplayLink Manager with multiple monitors? Is there any way to recover the apps?

  • Some tricks like cmd+tab, mission control <-> app etc work for me – anki Feb 19 at 16:46
  • Cmd+Tab does not work, because it will only focus the active window, which is not displayable. Mission Control shows the app, but as I said, it won't show up on the screen afterwards... – Martin Feb 19 at 16:48
  • maybe I'm misunderstanding the description, would a screenshot be possible ? – anki Feb 19 at 16:50
  • When you put an app in full-screen, the system creates a new space for it (without explicitly telling you that's what it's going), and sometimes that space can get lost off screen. Have you tried using ctrl-left-arrow or ctrl-right-arrow to see if you can find it? – Ted Wrigley Feb 19 at 18:22
  • @TedWrigley, the app is not in full screen. I really hope it was, then it would be easy to recover, and it would show up in Mission Control as a separate desktop... – Martin Feb 20 at 15:06
1

So, I don't know if this will work always, but I found one workaround:

  1. Switch to the non-showing instance of the app.
  2. Switch to another instance of the app that shows.
  3. Put this app in full screen
  4. Switch to the non-showing instance of the app -> now it worked for me.

I am not sure if 1-3 have to happen on the same monitor, I will keep trying this out in the next days...

| improve this answer | |
0

When I encounter this situation (or one similar) I quit Mission Control, which is a subprocess of the Dock, so really I quit the Dock

killAll Dock

The Dock and Mission Control and other children are immediately respawned and I have access to all my application again.

For me this occurs occasionally after I have changed the configuration of the displays attached to the computer, such as unplugging displays or plugging them in.

| improve this answer | |
  • I will try this, hope that is the reason... Fells like the old killing "explorer.exe" in Windows... ;) – Martin Feb 20 at 11:46
  • Happened again today, killall Dockdid not help, Dock was restarted, but the App still does not appear on screen... – Martin Feb 20 at 15:04
  • However, not to be unfair, the approach seems fine, might work with other situations than the one I had... ;) – Martin Mar 12 at 16:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .