0

I am currently using a 2017 Mac Pro touch bar that is still on Mojave 10.14.6. My safari is consistently shown using significant energy on my menu. In my activity monitor, I noticed there are many apps running behind my safari despite only opening 4 tabs: mailbox, youtube, google and apple stack exchange. Is there any way to remove the apps shown running as shown in the screenshot and to prevent safari from using significant energy? Screenshot for Safari activity monitor

  • Are you using any extensions ? – ankii Jan 24 at 10:46
  • The window is showing Avg Energy Impact over the past 12 hours. Current impact is almost nil, except for YouTube. – Tetsujin Jan 24 at 10:53
1

First off, the high number is the average energy impact, not the current.
This is in line with what you say you currently have open: merely 4 tabs.

Since I don't know what you have been doing before, I can't tell you exactly what might have caused this energy impact. But there is quite some cached Safari web content (Safari is using too much RAM. How can I reduce its memory footprint?, quite old though).

Probably the easiest way to solve the issue is to (force) quit Safari (Activity Monitor → Safari → in the left upper corner X → Quit/Force Quit) and restart your MacBook Pro.

If the problem persists try to delete web page cache with Safari → Preferences → Privacy → Advanced → Show Develop menu in menu bar, then in the menu bar at the top Develop -> Empty Caches.

You can also follow this guide, it also explains how to delete cookies:

Note: Flash Player is a notoriously bad extension (slow and unsecure). If you have it installed, remove it. You shouldn't need it these days. You can read more about it here:

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .