1

The Problem

On opening a new link when there are no Safari windows, but Safari is already active, Safari will hang (complete with beach ball) for ~10–30 seconds.

Reproduction Steps

  1. Have Safari open but with no windows
  2. Click a link in any app, open a bookmark with Alfred, or enter a URL with Alfred or Spotlight.
  3. If Safari opens both the link and a blank tab, Safari beach balls for between 10–30 seconds.

Specs

  • Safari v17.1 (19616.2.9.11.7)
  • macOS v14.1.1 (23B81)
  • MacBook Pro 14" (2021, M1 Pro, 32GB RAM)

Things I Have Tried

  • Disabling all extensions.
  • Occurs with or without a network connection.
  • Doesn't reproduce on a test user account.
  • Clearing website data: Settings > Privacy > Manage Website Data > Remove All.
  • Setting Safari as the default browser (previously BetterTouchTool was) from Settings > General > Set Safari as Default Browser.
  • Quitting BetterTouchTool just to be safe.
  • Restarting my Mac.

Things I have noticed

  • Whenever the hang happens, I have noticed that Safari will open a second, blank tab. So, although I have only clicked one link, two tabs open.
  • In Activity Monitor, the Safari process says it is using ~100% CPU when the beach ball happens. All the other Safari processes (extensions, networking SafariLaunchAgent, etc) seem normal.
  • Frustratingly, it doesn't happen every time! It will be fine for 3-4 fresh links and then the problem will reoccur. It doesn't matter what URL I go to. It doesn't happen at the same point. Sometimes happens before the page loads, and sometimes after the page loads. But always within about 60 seconds of the new window opening.
  • Clicking on Safari in the dock to open a new window, and entering the URL into the address bar, doesn't cause the fault.

I am a bit stumped about what to try next. Every time I think I've narrowed the culprit down, I manage to reproduce the problem. Suggestions for things to try or ways to narrow down the fault gratefully received!

1 Answer 1

0

In case anyone comes across this, as was suggested by @cornchip on the Mac Power Users Forum, I tried using Safari Technology Preview. Having installed it and set it as default the problem is resolved for now. A feedback has been lodged. Feedback FB13384650

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .