0

I am using a Mac mini 2010 with MacOS Sierra 10.12.6.

Today, I deleted and re-created my Finder preferences after the originals became corrupted.

Clicking on Finder (the blue smiley-face square) within the Dock did not work unless I went to Open New Finder Window.

The Desktop works, no issue there.

Is there a way within MacOS Sierra to get it to open automatically by clicking on the icon, like with other apps in Dock, such as Firefox or Terminal?

Any help is much appreciated.

  • Finder should always be 'open' ie active. If it has no windows open & no disk icons on the desktop, then nothing will appear to happen. – Tetsujin Dec 30 '19 at 18:08
  • There are icons on the desktop, that bit works... it's the dock that's the issue. – avenas8808 Dec 30 '19 at 18:10
  • Dock is not Finder. Can you please clarify what the actual issue is. – Tetsujin Dec 30 '19 at 18:14
  • The actual issue is clicking on the Finder icon in the Dock does not launch it directly. – avenas8808 Dec 30 '19 at 18:22
  • As I said, Finder is always launched; that's it's job, it never goes away unless you force it from Terminal.. so...What are you actually trying to do? – Tetsujin Dec 30 '19 at 18:24
1

Tick the second option listed in Mission Control Preferences. "When switching to an application, switch to a space with open windows for the application."

Mission Control Pref

| improve this answer | |
  • Thanks, that worked! +1 – avenas8808 Jan 11 at 14:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .