When I click on the Finder icon in the dock, it always used to open a new window for me unless I already had a window open. In that case it would bring that window to the front which was no problem. But now if I have no windows open, and I click on the Finder icon, no new window opens. I have to hit Command-N if I want a new window.

Which setting do I have to change, so that Finder will open a new window if there is not already a window open?

  • Are you sure you've got no opened Windows already? Perhaps a left over from a now disconnected display? Have you installed any Applications which will enhance the Dock? – Thecafremo Feb 4 '13 at 8:10
  • @Thecafremo No I am absolutely sure, when I option-click it, it shows that there are no windows currently open. – John Feb 4 '13 at 23:28
  • Did you reboot? – chmullig Mar 5 '15 at 1:35
  • I'm jealous. I'd love it if I could replicate this non-window opening behaviour! :-) – Kal Nov 7 '19 at 22:01

What about when creating a new user? Does that work over there or has it the same behavior?

If it DOES work on the new user, I would try this is in order inside the problem account:

It is (hopefully) unnecessary to mention that you want to create a backup of your machine first before trying the following steps, but I still felt the urge to do so.

  1. flush all cache files (~/Library/Caches/*.*)
    1. in Finder, open menu "Go", press down "Alt" and while holding click on "Library"
    2. navigate INTO the Caches folder and select every object you can find and remove them
    3. reboot the computer (logging in and out possibly does the same trick, but I want to be sure)
    4. empty the Trash at your leisure once logged back in
  2. check ~/Library/Saved Application States to see if there is a folder com.apple.Finder and dump it (if there is not, less work for you)
  3. This is more of a blunt measure, but I think still worth trying: create a folder on the Desktop, move all preference files in there and then test AFTER you logged out and back in. If it resumed working, try again with more and more preferences put back until either all are back in or the problem re-occurs. Occasionally, you may want to log out and back in as well to see if, after placing a file back, the behavior starts again. If removing all preferences does not bring the behavior back to normal, just move all back in overwriting every newly created one.

Until their respective preference files are back in, I would recommend not to open those applications (especially Mail) as this may have side-effects on your applications' settings and sometimes content becoming inaccessible (or more difficult to reach/get back).

The reasoning behind number 3 is that some preferences may not be viewed as the obvious origin, but still may have caused that. Removing them all and then putting them back one-by-one (or 5 at a time) makes sure that you can identify which file this has actually caused.

In the event that a newly created user has the same behavior (only then), you can try to install the latest combo update or re-install Mac OS X (no erase, just installing over the existing installation) to repair/re-add corrupted/missing files.

  • It worked! I followed @Phoenix’s instructions to a T, starting by creating a new user (which had the Finder behavior I wanted). There was no progress until I moved the contents of ~/Library/Preferences into a temporary folder on my ~/Desktop and restarted. (But, when I moved the 640 preference files back, I moved them in groups of 100 then rebooted, leaving behind in my temporary folder, any file that included in its name ‘finder’: files com.apple.finder.plist, com.apple.finder.plist.B7b6Gl6 (0 bytes), com.apple.finder.plist.K7w6Q3Y (0 bytes), and a folder called com.apple.finder). – Lucas Mar 12 '15 at 17:50
  • 1
    Good to hear! Just an addendum: All files in ~/Library/Preferences, which have random characters following .plist (like your com.apple.finder.plist.B7b6Gl6) can safely be removed. Those files are temporary files where the application creating it was unable to rename it to its proper file name (in your example to com.apple.finder.plist) or fill it with appropriate content. This can have various reasons, like the already existing file cannot be removed and recreated or permission issues properly writing to ~/Library/Preferences, etc. – Phoenix Mar 14 '15 at 10:02

This could well be down to bad prefs, for either Finder or the Dock.

Try running the following in Terminal and then testing the Finder icon again:

mv ~/Library/Preferences/com.apple.finder.plist ~/Library/Preferences/com.apple.finder.plist.BAK
killall Finder
mv ~/Library/Preferences/com.apple.dock.plist ~/Library/Preferences/com.apple.dock.plist.BAK
killall Dock

If that doesn't work, you can restore your old prefs with the following:

mv ~/Library/Preferences/com.apple.finder.plist.BAK ~/Library/Preferences/com.apple.finder.plist
killall Finder
mv ~/Library/Preferences/com.apple.dock.plist.BAK ~/Library/Preferences/com.apple.dock.plist
killall Dock
  • Great idea but it didn’t affect the Finder at all. I am suspicious about the computer actually having complied with my commands: e.g. I keep my dock vertical on the right and expected it to default to the bottom after renaming the preferences file and killall’ing, but it came back exactly where it’s always been. – Lucas Mar 5 '15 at 14:25
  • I would be surprised if that did work. See my answer here why and how to reset a preference. apple.stackexchange.com/questions/175573/… Note that it will wipe the preff – markhunte Mar 9 '15 at 18:11

I ran the first line of code you shared mv ~/Library/Preferences/com.apple.finder.plist ~/Library/Preferences/com.apple.finder.plist.BAK killall Finder and I managed to get my Finder window to work again.


just click on force quit and relaunch it it will open in usual way.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .