Since one year I'm using a MacBook Pro 13 upgraded to Catalina in October. I use the Mac to program same embedded module via RS232 (different adapters with different chips, e.g. FTDI) and it is still working.

Last Monday I changed to a new MacBookPro 16. I used a backup and all worked proper, but I can't connect to any USB-to-Serial adapters. I got the same

error [16] could not open port /dev/tty.usbserial-xxxx: Resource busy ...

I tried to reinstall all corresponding drivers, but without success.

  • When you say you reinstall and have no success are you asking for help to find the installer logs so you can see what failure was logged?
    – bmike
    Dec 5, 2019 at 12:12
  • Yeah, that could be the first step. In the meantime, I passed the USB port to a virtual machine, where I could access it without any problems, but not under macOS.
    – andyfreund
    Dec 5, 2019 at 12:37

1 Answer 1


Per Troubleshooting CH340G issues on macOS it could be a conflict between drivers eg. Apple's com.apple.DriverKit-AppleUSBCHCOM.dext and a third-party usbserial.kext. Disabling and removing drivers might help. I just restored access to /dev/tty.usbserial-1410 for an old LOLIN32 Lite ESP32 module by unplugging it and running:

sudo kextunload /Library/Extensions/usbserial.kext/
sudo rm -rf /Library/Extensions/usbserial.kext/

You can plug it back in after the first line to see if it helped. If so, proceed. If not, don't.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .