9

After updating to Yosemite the only trouble I have is that VMWare Fusion (Professional Version 5.0.5 if that helps) fails to start showing following error:

Could not open /dev/vmmon: No such file or directory. Please make surethat the kernel module `vmmon' is loaded.

I've tried to google the issue but the only relevant thing found was this:

The Mac has a certain amount of devices it can register in the /dev/ directory ..., virtual devices like virtualization software and VPN clients also create devices in this directory quickly filling up the number to the limit. To solve this I went through my installed applications and removed every VPN client and VM software that I don’t require any longer and rebooted my machine. After the reboot everything worked immediately.

But even if this is true, I just can not get rid of my VPN client for example. So, I still have no idea what steps I should take to solve the issue. I'll be very much obliged for any hint how to fix this problem.

11

After having this issue with macOS High Sierra and VMWare Fusion 8.5.8, I was able to resolve it by allowing the system extension as described in http://planetvm.net/blog/?p=3240

In short; open System Preferences, click Security & Privacy, and from the General tab you should see a message stating System software from developer "VMware, Inc." was blocked from loading. Clicking the Allow button resolved the issue for me.

  • This was the solution for me in OS X 14 "Mojave". – Sushil Feb 2 at 18:26
5

In case anyone is running into this with VMware Fusion 6 on Yosemite... I had the same issue and it seems OS X only has a limited amount of major device numbers, which are used by many different device drivers. VMware Fusion tries to load its device drivers on app startup, so if every major device number is already occupied, the drivers won't start.

A VMware employee presented some ways to find out which drivers are using major device numbers in this post: https://communities.vmware.com/message/2341918#2341918

When I ran ls -l /dev/ | grep '^c' | sort -nk 5 I discovered that FUSE for OS X and Tuxera NTFS each appeared about 20 times. I don't know for sure how to stop/restart these drivers - I had the luck that FUSE for OS X asked to update itself after I opened its preferences pane, this caused all fuse devices to disappear.

After this, VMware Fusion was able to its drivers and the VMs booted again.

Edit: I had the same issue again after using a VeraCrypt mounted image. This command line unloads the FUSE for OS X kernel extension if no filesystems are mounted:

sudo kextunload -b com.github.osxfuse.filesystems.osxfusefs

  • Thanks! In my case it was the tuxera ntfs driver com.tuxera.filesystems.tufsfs.fusefs_txantfs – kim0 Dec 29 '16 at 13:49
  • 2
    And for me it was com.github.osxfuse.filesystems.osxfuse You can view loaded kexts doing sudo kextstat on the terminal – WayToDoor Jun 14 '17 at 12:49
5

It looks like simply unloading a kernel extension which is using one of the major character devices is enough to get around the problem. For example, I had /dev/HAX so I was looking for instructions for uninstalling HAXm. I found https://stackoverflow.com/questions/38354287/uninstalling-intel-haxm-on-mac-el-capitan which mentioned running sudo kextunload -b com.intel.kext.intelhaxm. After I did that, I was able to start a VMWare Fusion virtual machine without having to reboot.

  • This was the only thing that worked for me. Thanks! – nyxgeek Jul 21 '17 at 16:41
  • This worked for me on July 31 2017. I'm on OSX Sierra Version 10.12.6 (16G29) using VMWare Fusion Version 8.5.8 (5824040). I didn't even know I had intelhaxm installed, but executing this command resolved the issue. – Jimmie Tyrrell Jul 31 '17 at 22:34
2

According to a VMWare employee, VMWare Fusion 5.x is not compatible with OS X Yosemite, and recommends upgrading to version 6 or above. See the answer in this thread here: https://communities.vmware.com/message/2451191#2451191

I was running into a similar problem and upgrading from Fusion 5 to Fusion 6.0.5 solved it for me.

  • 1
    I'm running into /dev/vmmon issue on macOS Sierra (10.12.5) and VMWare Fusion 8.5.8. So I'm not sure that the issue is as simple as using a different version of VMWare. – M. Scott Ford Jul 17 '17 at 19:58
2

I had this same problem running Mac OS Mojave 10.14, VMWare Fusion 11.0.0, Macbook Pro 2017, and could not get the issue resolved until I rebooted my Macbook Pro. After restarting it, I launched VMWare Fusion and was prompted to allow it to access some resources by going to System Preferences > Security & Privacy, and selecting allow.

Your Apple computer may ask you to allow VMWare Fusion specific access as soon you open the app. If that's the case, just allow it and your VM's will work just fine. Thanks to everyone above for contributing to the conversation and for the solutions being suggested above.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .