2

I boot my iMac from an external SSD, which is a clone of my main HDD, running Mojave. I had no issues before, recently with the Catalina being released I downloaded the update and when I choose my SSD drive I get: "this volume is not formatted as APFS".

What should I do now? I tried from recovery to convert it, but the option is disabled.

Is the only way to format it? or is there another way I am not aware of?

1

It turns out there was no way to change my SSD to APFS without formating. I ended up using "carbon copy cloner" cloned my SSD to internal hard drive, then formatted my SSD to APFS, and cloned everything back to SSD. All good now and I was able to upgrade without trouble.

|improve this answer|||||
  • "It turns out there was no way to change my SSD to APFS without formating." — How did you come to this conclusion? – Jivan Pal Nov 26 '19 at 9:19
  • 1
    From apple forums, and trying to do it myself from recovery, I tried different ways before going to formatting. Your method might work but I can't test it now. Hope it helps someone else who might be going through the same thing. – Kash Nov 26 '19 at 13:22
0

Let's find out why Disk Utility isn't letting you convert your partition. In the Terminal, use diskutil list to determine the device node name for the HFS partition you want to convert (e.g. disk1s2) and then use diskutil apfs convert <device> -dryrun, e.g. diskutil apfs convert disk1s2 -dryrun. If it fails, edit your question, adding the output of that command.

If the dry run succeeds, then actually attempt the conversion with diskutil apfs convert <device>, e.g. diskutil apfs convert disk1s2. Again, if that fails, edit your question, providing the output.

As with any situation where you're messing with partitions, ensure you have a backup of your data beforehand.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .