2

I have 1TB Internal SSD and 512GB SD card in a SD slot.

I can create a fusion drive in HFS+ format, and the drive was running fine on my previous El Capitan system. Now that I upgraded my system to Catalina, I wanted to format this fusion drive volume in APFS (currently running Catalina from external hard disk drive, not this fusion drive). But the conversion always fails with either of these 2 error messages:

1:----------------------------------
A problem occurred during conversion from HFS to APFS
APFS Converter exit code is 1
Aborted conversion in commit mode so will restore type
Setting type of disk0s2 to CS
Changing the physical disk partition type in shared mode
Partition modification attempt count was 1
Setting type of disk4s2 to CS
Changing the physical disk partition type in shared mode
Partition modification attempt count was 1
Not mounting APFS Volume
Exiting conversion operations with error code -69860
Error: -69860: The underlying task reported failure on exit

and

2:---------------------------------
It looks like you are trying to create an upside down Fusion:
Main tier (988 GB) is larger than Tier2 (462 GB)

I have no clue about the error message 1, but assuming from the error message 2, APFS fusion drive can not be created if the main drive ( SSD ) is larger than the secondary one? If so, is there a way to force it to make the fusion drive anyway?

what I did to convert:

  1. diskutil apfs convert disk1
  2. diskutil apfs createContainer disk1 disk2
  3. from Disk Utility's Edit menu: "Convert to APFS" ( unmounted the target volume first too )
  4. used a Carbon Copy Cloner and cloned Catalina's bootable volume on external hard disk to the target fusion drive
  5. from OSX Catalina Install Disc

I'm really stuck now. Is there anything else I can try? I appreciate your help, thanks...!

6
  • 3
    It tells you what the problem is, you can’t have a fusion drive where the first drive is larger than the second. The SD card has to be the primary. Secondly, why are you trying to do this with an SD card?!? It’s nowhere as fast as your SSD and they have much higher failure rates. This setup should be abandoned. – Allan Jan 11 '20 at 12:50
  • 1
    I'm with @Allan - don't even bother with this idea, it's not a good one. The whole idea - now very much out of fashion as SSD prices have fallen - is that a tiny SSD acts as a fast cache to a slow old HD. It was fine for its time. It is going to be nothing but trouble trying to do it with a small SD card - apart from the fact they're slow as anything & hideously fail-prone - & a large SSD that's perfectly capable of handling all this itself. – Tetsujin Jan 11 '20 at 14:00
  • @Allan because my MacBook Pro needs more space, 1TB isn't enough but can't install another hard disk nor SSD. The only option is the SD card, the one I have fits there without any protrusion so never need to be detached... Yes, compared to internal SSD, SD card is quite slow but I use TimeMachine so I can ignore about failure rates. Just need more space for cache/swap files ( for photo/video editing ). – alpacat Jan 11 '20 at 15:24
  • 1
    The SD card will not give you more space as a fusion drive, only as a separate volume. Fusion drives are a caching solution, not an additional storage solution. – Tetsujin Jan 11 '20 at 16:04
  • 1
    I really don't know. It makes no sense whatsoever in HFS, even less in APFS which doesn't like Fusion drives or HDs at all, it likes SSDs. Maybe someone realised it had a loophole allowing a poor setup as you are trying to create & just closed the hole. Whether it 'worked' before or not is really a moot point. By definition of how Fusion works, you are actually trying to make your structure perform worse than without it. I cannot emphasise enough that it is a terrible idea. Just use the SD as extra storage… though don't rely on it, keep backups. – Tetsujin Jan 11 '20 at 17:39
2

I finally took the plunge and upgraded my iMac to Catalina. It originally had the fusion drive with SSD and spinning hard drive. However, I upgraded the HDD to a Samsung SSD and combined it with the original SSD to create one large CoreStorage logical volume (can’t call it “Fusion” anymore.”)

While trying to convert this logical volume, I ran into all of the same issues you did, so I was able to replicate the problem. However, after about an hour of throwing to force things, I found the trick: reverse the order of the drives

What you think it should be:

$ diskutil APFS create disk0 disk1 “MyVolume”

Reverse the disk identifiers to make it work

$ diskutil APFS create disk1 disk0 “MyVolume”

(I’ll post all of the command output shortly...I’m posting from my iPad as Catalina installs onto a APFS “Fusion” drive).

1
  • Did this ever work? I’m in the thick of it and between trying to get apfs to work instead of CoreStorage, Fusion to work on a faster drive that is also bigger and an issue with Preboot, I’m about at my wits end! – bafromca Aug 12 '20 at 8:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .