0

Today I upgrade to Catalina 10.15

When I go to Finder and try to open any location that is on my iCloud I get the following message

“Desktop” can’t be opened because the original item can’t be found.

Where Desktop is the location I am trying to access

1

I had the same problem. I fixed it by removing Documents and Desktop from the Finder sidebar and then adding them back.

Here's how to do it

  • Open Finder.
  • On the Finder sidebar, right-click (or Ctrl-click) on Documents and choose Remove from Sidebar. Do the same thing for Desktop.
  • On the menu bar at the top, click Finder and choose Preferences.
  • Click the Sidebar tab at the top.
  • Check the box for Documents and Desktop.
  • Close the Finder Preferences window.

NOTE: I've read that some users have a similar problem that might be related to iCloud and having the Documents and Desktop folders synced there. I don't use iCloud for these things, so I can't say if the problem is also caused by that.

New contributor
NickInSoCal is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .