When I try to access my 2Tb Transcend StoreJet External Hard Drive in Finder, I always get the following error:

enter image description here

However, 16Gb USB Flash Drive can be accessed without any problems.

I cannot also see any obvious reasons for that looking at disk info:

enter image description here

Running First Aid with Disk Utility and restarting Finder didn't solve the issue.
masOS version is High Sierra 10.13.2. Also there is no problem to access this HDD_2Tb drive on Windows OS.

Here is the output from Terminal:

# ls -lt /Volumes/
total 320
lrwxr-xr-x  1 root      wheel          1 Dec 13 19:21 Macintosh HD -> /
drwxr-xr-x+ 3 root      wheel         96 Oct 23 22:40 Preboot
drwxrwxrwx  1 _unknown  _unknown  131072 Jan  1  1980 HDD_2Tb
drwxrwxrwx  1 _unknown  _unknown   32768 Jan  1  1980 USB_16Gb

Any suggestions are welcome.

  • Are you attempting to access/save/recover data stored on the drive or do you just want to access the drive?
    – Allan
    Dec 17, 2017 at 13:48
  • I'm trying to read the data stored on this drive or at least to see the filesystem tree.
    – DimaSan
    Dec 17, 2017 at 13:50
  • 1
    what do you get when do an ls -lt /Volumes/HDD_2Tb ?
    – Allan
    Dec 17, 2017 at 14:23
  • Wow, it really shows the files on this drive! So the problem is probably with Finder?
    – DimaSan
    Dec 17, 2017 at 14:29
  • 1
    @Joe It at least cleared out any stuck processes etc.
    – nohillside
    Jan 21, 2018 at 18:40

10 Answers 10


Just go to Apple menu then go to force quit then relaunch the Finder. It worked for me.

  • 6
    Thanks, but relaunching Finder didn't work for me.
    – DimaSan
    Dec 20, 2017 at 9:38
  • 5
    What worked for me was holding "option" then right-clicking Finder on the dock, then clicking "relaunch". That worked like a charm.
    – kbpontius
    Jan 17, 2018 at 20:18
  • You can use the Activity Monitor to Force Quit the Finder in newer Macs
    – Kebby
    Dec 15, 2021 at 21:37

I had the same issue.

Restarting with the hard drive mounted did the trick

  • Good old "restart and hope for the best" solved my issue, too. Nov 3, 2019 at 18:20

Try the following:

  1. Unmount the drive
  2. Remove the icon from the Finder sidebar
  3. ls /Volumes to make sure that HDD_2Tb is not listed. If it is then reboot without the drive connected and check again. If it persists then rm /Volumes/HDD_2Tb making sure your drive isn't connected.
  4. Reboot with drive connected.
  5. Open a Finder window and right click on the title so you can navigate up to the machine level.
  6. You should see the drive, now double click on the icon.

That should flush all the required caches and allow the drive to remount properly.

  • The drive appeared in Finder after I run the long test from third-party app DriveDx and now I can read data from it, however that test did't find any errors. Thank you a lot for this advice, I will try it once it happens again.
    – DimaSan
    Dec 17, 2017 at 23:22

Since the drive is mounting properly as evidenced by you seeing it in Terminal and in Disk Utility, your next step is to make sure that your Finder Preferences are set to show External Disks.

Go into Finder Preferences (Command,) then navitage to the Sidebar tab. Scroll down until you come to "External Disks" and make sure it's selected.

enter image description here

Next, eject the drive and delete the mounted folder if necessary.

$ sudo diskutil eject disk2
$ sudo rm /Volumes/HDD_2Tb

Then unplug the drive, verify that the mount and folder no longer exist, then plug the drive back in. This should cleanly mount everything again.

  • Thanks for suggestion Allan, but I had this checkbox to show external drives.
    – DimaSan
    Dec 20, 2017 at 9:38
  • Does it show on the desktop?
    – Allan
    Dec 20, 2017 at 9:40
  • Neither as well.
    – DimaSan
    Dec 20, 2017 at 9:41
  • I placed a command in the comments of the question...run that and let me know what happens.
    – Allan
    Dec 20, 2017 at 9:42

I had the same issue. I had formatted my pen drive and when formatted the disk changed into a alias file in the sidebar. Just remove the alias from the sidebar, then go to your home folder and you will find it over there.


I was able to fix this by doing the following:

starting my mac in recovery mode by holding cmd + opt + r
selecting disk utility
clicking mount for my SSD
clicking first aid
restart my mac


If you have a similar problem like this.

and if you can actually list the mounted drive from the terminal like so:

MyMac:~ root# df
Filesystem    512-blocks       Used  Available Capacity iused               ifree %iused  Mounted on
/dev/disk1s1  1953595632  437825216 1486309400    23% 2609168 9223372036852166639    0%   /
devfs                413        413          0   100%     715                   0  100%   /dev
/dev/disk1s4  1953595632   27947072 1486309400     2%      13 9223372036854775794    0%   /private/var/vm
map -hosts             0          0          0   100%       0                   0  100%   /net
map auto_home          0          0          0   100%       0                   0  100%   /home
/dev/disk5s1  3907024000 1256704032 2650319968    33%  116175          1325160801    0%   /Volumes/SAMSUNG

Then try to list content of the mounted volume:

MyMac:~ root# ls -lt /Volumes/SAMSUNG
total 28536
drwxr-xr-x@ 1 root  wheel     4096 31 Mar 20:12 $RECYCLE.BIN
drwxr-xr-x@ 1 root  wheel        0 14 Jun  2017 .fseventsd
drwxr-xr-x@ 1 root  wheel     4096 11 Jun  2017 Rocksmith 2014
drwxr-xr-x@ 1 root  wheel        0 21 Oct  2016 .Trashes
drwxr-xr-x  1 root  wheel        0 25 Jan  2016 .Trash-37044
drwxr-xr-x@ 1 root  wheel     4096 23 Jan  2016 System Volume Information
drwxr-xr-x  1 root  wheel        0 16 Jan  2016 .Trash-1000
-rwxr-xr-x  1 root  wheel  6160384 14 Jan  2016 test_write2.dvr
drwxr-xr-x  1 root  wheel        0 14 Jan  2016 ALIDVRS2
-rwxr-xr-x  1 root  wheel  6160384 14 Jan  2016 test_write1.dvr
drwxr-xr-x@ 1 root  wheel        0 27 Jul  2015 Samsung Software
drwxr-xr-x  1 root  wheel     4096  6 Jan  2015 User Manual
drwxr-xr-x  1 root  wheel     4096  6 Jan  2015 Samsung Drive Manager Manuals
drwxr-xr-x  1 root  wheel        0  6 Jan  2015 Samsung Drive Manager
drwxr-xr-x  1 root  wheel        0  6 Jan  2015 Macintosh Driver
-rwxr-xr-x  2 root  wheel   166488 17 Dec  2013 Samsung_Drive_Manager.exe
-rwxr-xr-x  2 root  wheel  1407568 17 Dec  2013 Portable SecretZone.exe
-rwxr-xr-x  2 root  wheel   712704 17 Dec  2013 Secure Unlock_win.exe
-rwxr-xr-x  1 root  wheel      120  6 Dec  2013 Autorun.inf

and if any of the methods described in the linked issues does not work for you. Try to access the mounted volume directly in Finder like so

enter image description here


The other solutions didn't do it for me.

I simply restarted. Everything is back to normal now. My flash drive didn't have to be plugged in while booting up.


In my case there was a problem with connecting to the Time Capsule and opening the user folder.

The problem seems to be in the camel case of the username of the user connecting to the folder. It said "Conected as Ricardo" while the correct username and the folder name was "ricardo" (lowercase). This way, I was always getting the message "The original item can't be found".

After clicking on Disconnect (top right) then Option + Click Reconnect it opens the username dialog, where I could change to "ricardo".

Tip #2: you need to click on eject button before relaunching Finder as recommended here.


I recommend restarting the mac. But if you are in a situation you are unable to restart you can open up the directory using Disk Utility.

Launch Disk Utility using spotlight search (command+space type Disk Utility)

It should list your drive. Select the sub item right-click on it, choose 'show in Finder' e.g. enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .