0

On my iPhone SE, I found that my "Default Account" for Contacts was iPhone. That was why newly created contacts would not sync with an Exchange Server. So I changed it to Exchange. I did not like the fact that migrating the iPhone contacts to the Exchange account needed either a 3rd party app or transferring through the cloud in some way. So I handraulically re-typed the contacts as new contacts in the "All Exchange" group. I made sure that the "All iPhone" group was unchecked. This caused the new contacts to sync with Exchange Server.

To tie up lose ends, I made sure that only the "All iPhone" group was checked, then deleted the re-typed contacts from that group. Then I made sure that only the "All Exchange" group was checked. Lo and behold, the contacts were gone.

1) Is this a bug?

2) How do I avoid this?

3) And how do I prevent Contact settings from switching to iPhone? I seem to be always switching it back over the years, after being burned repeatedly.

Thanks.

2

All iPhone [or All iCloud if you have that set up] is the 'master list'.
All contacts are in that list.

All other lists are sub-sets of that.
Anything not in any sub-set will only appear in the master list.

If you delete something from the master list you are also deleting it from any & all sub-sets.

  • Thanks,Tetsujin. I guess there is no account for Contacts that are only stored locally on the iPhone and nowhere else? That's what I mistakenly thought "All iPhone" meant. – user2153235 Sep 7 at 15:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .