0

I have my work exchange account added to my iphone. The problem is when I add a contact in my iPhone, the contact is automatically stored in the exchange account group. This I do not want. Is there a way that I can turn this bug/feature off?

Ideally, there should be an option to confirm which phone book I would like the contact added to. Or at minimum have an option to save all contacts to the icloud.

Investigating a bit, it appears that if at any time in past I would have selected the exchange group contacts, then when I add any new contact it goes to the exchange account. Subsequently, the only time I see that contact is when I show the exchange group in the contacts app again.

Many times I forget to unselect the exchange group contacts and then weeks or month later add someone to my contacts which then gets stored only in the exchange group contacts. It doesn't get copied to the icloud even!

1

Settings > Mail, Contacts, Calendars > (contacts section) Default Account.

(Note default account also exists in the "Calendars" section.)

I personally wish Apple would let you set which group, on the fly, as you save the contact, but sadly we can only change the "default".

  • Thanks! But I already have a different account selected as default for contacts. – shparekh Aug 23 '15 at 5:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .