1

My 15-inch MacBook Pro (Touch Bar, mid-2017) has always been plagued by issues with sleep.

After not using it for a few months, I started using it again yesterday and found out that during the night it drained about 50% of the battery on its own and went into "Low-power sleep" at about 6 AM (the type of sleep that you can only wake from by reconnecting the power adapter).

Here’s my setup:

  1. I use an external display with my MacBook, however the two were physically disconnected (USB-C to Thunderbolt adapter is unplugged) during the night;
  2. There were a Bluetooth keyboard by Lofree and a second-generation Magic Mouse connected;
  3. Among other apps, Spotify, Telegram, iOS Simulator, XCode, Google Chrome and Firefox were running. I mention these because I once noticed Spotify seemed to prevent sleep. I’m not sure it was the culprit in this case;
  4. In Energy Saver, the following settings are engaged:
    • Under “Battery”:
      • Put hard disks to sleep when possible;
      • Slightly dim the display while on battery power;
      • Enable Power Nap while on battery power;
    • In “Power Adapter”:
      • “Prevent computer from sleeping automatically when the display is off” is disabled
      • Wake for Wi-Fi network access
      • Enable Power Nap while plugged into a power adapter

I am aware Wi-Fi network access and Power Nap may be the culprits here, although if I remember correctly, past experimentation with these settings proved inconclusive.

Moreover, I’m reluctant to disable Power Nap because it allows the Find My Mac feature to work correctly, and I’d like to keep that functionality intact.

I’ve uploaded the output of pmsleep -g log in hopes that it helps troubleshoot. Reading through it I couldn’t locate a clear culprit. You can find it here: https://gist.github.com/gabrielecirulli/34462c195d703a577f23a80c3fc9dd28

1

Broadly speaking, what I would do next is as follows:

1. Quit all applications and put the MBP to sleep overnight. Then,

  • If it's still draining battery power significantly, it's time to reset the System Management Controller (see below)
  • If it didn't drain the battery much during the night, then proceed the following night with only two or three apps running.
    • If it significantly drains the battery, then you've narrowed it down to one of those apps, so repeat the process until you identify the culprit.
    • If it doesn't drain battery, then repeat the process the following night with a different group of apps and repeat the process until you narrow down the app(s) causing the problem.

2. Reset the SMC

  1. Fully shut down your MBP.
  2. Press and hold the power button for at least 10 seconds
  3. Let go of the power button and wait 5 seconds
  4. Power up your MBP again

Once you've reset the SMC test your MBP again. If it's still misbehaving, reset the SMC again but with the following steps instead:

  1. Fully shut down your MBP.
  2. Press and hold the right shift key and the left option and control keys for 7 seconds before then also pressing and holding the power button (or Touch ID button) down for another 7 seconds (i.e. the keys will end up being held down for 14 seconds, the power button for 7 seconds)
  3. Let go of all three keys and the power button
  4. Wait 5 seconds
  5. Power up your MBP again

Now test your MBP again. If you're still having problemss, let us know.

  • An easier check for the SMC is logging out before letting it sleep – John Keates Jul 28 at 14:45
  • Thank you for this answer. I ran into the actual solution a bit by accident because the Lofree keyboard I have ran out of battery, and the behavior stopped repeating. I experimented a bit more with turning off the keyboard when away from the computer and it doesn't appear to wake anymore. So it looks like the keyboard was the actual culprit! I plan to solve this by switching to a different keyboard, however another solution that works is to turn off the ability for Bluetooth devices to wake the computer by going to the Advanced section in Bluetooth Settings. – Gabriele Cirulli Jul 29 at 12:35
  • You can add it as an answer to your own question and use it to mark this resolved. – John Keates Jul 30 at 1:56
  • @GabrieleCirulli I'd write that up as an answer so that others are more likely to notice (and be helped) by it. – Monomeeth Jul 30 at 1:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .