I'm using Apple Magic Keyboard on Windows 10 (not a Bootcamp, standalone machine) and overall it works fine with Bootcamp drivers from Apple but funny enough "functional" button is not functioning. Again, it is not a Bootcamp (I have it too, it works fine for me) and I already installed keyboard driver from Bootcamp package.

I tried this and this but those answers didn't work

I found Magic Keyboard Utilities and they work great, but it is not a lifetime thing, it is a subscription and I'm allergic to subscriptions 🙂

Do I have any other options? Did I miss anything?

Any help is appreciated, thanks!


I tried:

  • different flavors of AppleWirelessKeyboard and I wasn't able to make it work on Windows 10
  • uawks and it seems to be quite since 2010 (development stopped @2008)
  • to install bootcamp.msi but it's control panel didn't run and overall it was useless (see picture below):

enter image description here

I didn't try: - WinAppleKey because I can't use TESTSIGNING on my Windows PC

  • If you already found what works.... Commented Jul 26, 2019 at 4:36
  • @ThomasNelson it doesn't without Magic Keyboard Utilities ... Commented Jul 26, 2019 at 16:21
  • @Thomas Nelson Not only is it paid software but it's a subscription and per device. This is not something most people would be able to morally support. Commented Jul 31, 2019 at 10:32
  • How does it work with Bootcamp but not with a Windows PC? What part is apple installing that we are missing on a PC if we install the Bootcamp drivers?
    – kiatra
    Commented Jan 23, 2020 at 13:58

2 Answers 2


Have you looked at this: https://github.com/gered/AppleWirelessKeyboard/releases the project has been abandoned but it might work.

This might also work... https://uxsoft.cz/Projects/AppleWirelessKeyboard

  • Unfortunately, even basic functionality like "delete" button (fn+backspce) doesn't work - so I can't press ctrl+alt+del and login Commented Aug 1, 2019 at 17:42
  • Wasn't it CTRL-ALT-Fn-DELETE on the apple keyboard? Commented Aug 2, 2019 at 0:15
  • it Is CTRL-ALT-Fn-BACKSPACE but since Fn is not functional ... 🤷🏻‍♂️🙂 Commented Aug 2, 2019 at 4:44
  • Wow that's some FU. If neither of the open source things work (and the uxsoft.cz project at least looks like its under development and still alive.) you might be out of luck. I know that you don't want a recurring payment like that but they may be the only ones that figured out enough to get it to work. Commented Aug 2, 2019 at 4:56

This resource was my savior. I only used these regedit lines they suggest:

To reverse the fn key behavior, open RegEdit and navigate to HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\KeyMagic\ and update OSXFnBehavior key from 01 to 00 (in the binary editor this will update from 00000000 01 . to 00000000 00 .).

Not sure if this is necessary, but also navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\KeyMagic\ and make sure the OSXFnBehavior key has the same value.

Restart your PC for the registry changes to take effect.

I'm pretty sure I never installed Bootcamp on my system, so I'm not sure if the Regedit fix just works by default ... or if it worked because I installed and uninstalled other tools that promised to fix the issue (like the ones mentioned above). Since the reg-entry is called "KeyMagic" I guess it must have somehow ended up on my system (Windows 10). So you might have to use the other steps there.

I tried a ton of tools from the net - none worked, as they use the Bluetooth connection, which the Mac A1243 keyboard doesn't have. Other suggestions were to change BIOS settings, but they don't affect external keyboards. And there is no key combination on this apple keyboard to that fn-unlocks again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .