2

I am facing a super stupid problem which is completely killing my productivity.

I have my laptop attached to an external monitor. Desktop 1 is on the laptop and desktop 2 is on the external screen. From desktop 2, I open a PDF file with preview.

Instead of opening it inside desktop 2, it automatically switches whatever is full screen on my laptop monitor and opens the PDF on desktop 1.

This is driving me mad. Why isn't the default behavior the obvious one? (namely open the window exactly where the open command comes from)

Is there anything I can do to make it behave in the logical way?

Thanks!

ps: MacOs 10.14.4 Mojave

edit: adding picture regarding comment enter image description here

  • 1) Is Preview already running when you do this? 2) Right click Preview's icon in the Dock & tell us what is selected in Options>Assign to... – Tetsujin Jun 4 '19 at 19:51
  • 1
    @Tetsujin The behavior is the same wheter preview is already open or not. Weird I don't have 'assign to' in the options list in the dock ( I have 'keep in dock', 'open at login', 'show in finder', none checked) – ClonedOne Jun 4 '19 at 19:53
  • All apps have an assign to [desktop]; I've never seen one without. – Tetsujin Jun 4 '19 at 19:56
  • Have you set your external monitor as primary screen on system preferences? I can't see the "assign to" option either. – LvcasX1 Jun 4 '19 at 19:57
  • 1
    @LvcasX1 thanks for the tip! now I can see the option. However that's not really answering the question, I would like preview to just open where I am working, not in a fixed place. If for instance I was working on the laptop monitor I would want it to open there – ClonedOne Jun 4 '19 at 20:09

You must log in to answer this question.

Browse other questions tagged .