11

A normal Finder window used to open when I pressed Option + Command + Spacebar but not its a Search window. I know this happened once and I found how to fix it but I can't find it anymore.

1
  • 1
    Command + Option + T makes the sidebar appear again
    – PsaeBrail
    May 15, 2019 at 22:26

3 Answers 3

14

I found a solution to the issue. OptCmdSpace has always been a command for showing a "finder search window". If you now just see a window without the sidebar just do this:

  • press OptCmdSpace To open this window
  • Press OptCmdT or go to "view>hide toolbar".

Sometimes we just press it accidentally and this hides the toolbar, which makes this searching window into a "normal finder window".

2
  • You should have received a notification explaining why your first post was deleted. Please have a look at the faq to understand how the site works.
    – nohillside
    Nov 27, 2019 at 12:26
  • Excellent answer!
    – ToniAz
    Mar 28, 2020 at 1:07
6

look in system preferences > keyboard > shortcuts pick spotlight. see Show Finder search window. maybe it got unchecked?

enter image description here

4
  • 1
    It's checked. The finder window pops up but it doesn't have the left sidebar its shows "Searching This Mac" with a search bar
    – PsaeBrail
    May 15, 2019 at 22:21
  • 1
    The question asks how to toggle Finder from "Search this Mac" mode to regular folder browsing mode. The shortcut to launch Finder is working for them, it's just that Finder is not launching in the desired mode.
    – Robino
    Sep 3, 2019 at 11:20
  • Needed to disable this. Thank you!
    – sqreept
    Apr 5, 2023 at 12:45
  • After solving this 4 years ago and forgetting how, I'm back. This time I'll write up the how-to
    – Robino
    Jul 14, 2023 at 20:26
0

Just like the OP, I randomly started getting the dreaded Searching "This Mac" edition of Finder when running the shortcut / keychord: OptCmdSpace

Previously, like just a few hours ago, I was getting Finder launching in the Documents folder. This was so frustrating for me that I have been trawling the internet for help and using my extremely basic automation skills to scratch together something to make this nightmare go away. It may not be pretty, but it is, at the time of writing, the only correct solution to the OP that I have found. Brace yourself.

Instructions

  • Install hammerspoon. This is a scripting automation tool for mac and has been around a long time.
  • Disable the shortcut in System Settings (formerly System Preferences) by navigating: Apple icon (top left of your screen) > System Settings > Keyboard > Keyboard Shortcuts > Spotlight > "Show Finder search window" (uncheck). More instructions on this: How to prevent Option+Command+Space from opening "Searching This Mac"?
  • The hammerspoon icon should load in the menu (top right). Click the icon and select "Open Config".
  • If it does not, find the init.lua config script yourself by going to Finder, pressing the shortcut ^ShiftCmdG for "Go to" and paste ~/.hammerspoon/init.lua. Hit enter.
  • Open this file in an editor. TextEdit, VSCode, whatever you like.
  • Paste in this code at the top:
-- Listen for the launch finder shortcut and then run the function
hs.hotkey.bind({"cmd","alt"}, "space", 
    function() 
        -- Launch Finder from prompt
        hs.execute("open -R ~/Documents")
    end
)
  • Save the file.
  • back to the menu bar to reload: hammerspoon icon > Reload Config
  • You're all set!

If this sounds like too much work for the productivity gain, here are some workarounds that I have considered over the years:

  1. ^ShiftCmdO takes you to Documents. So you can press this combo to achieve the same:

OptCmdSpace >> ^ShiftCmdO

I don't like this because the left fingers need to dance about the keyboard quite a bit.

  1. OptCmdSpace >> CmdT

This opens Finder with "Search my mac" but then the second commmand opens a tab navigated to your default location. Easier shortcut as you just lift a finger off with one hand and hit t with the other. Annoying to close with cmdw because it's an extra "w".

  1. Like 2 but with N instead of T. Extra window can be annoying but N is easier to hit after space than T.

  2. There is an easier - a completely trivial - way. Like @PsaeBrail says in his qn: I know this happened once and I found how to fix it but I can't find it anymore. I can vouch for this. In 2019 I had this issue and searched for days until I found it. I don't remember what it was but it was a simple shortcut in Finder. If you know, please share it with us. If you don't, at least you have a hack to help you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .