3

If you search for a file in Spotlight and command-click the file you expect the Finder to activate and show that file. Instead, the Finder activates but only shows my home folder.

Same thing in Terminal:

open /Users/myHome/Documents/aa/ab

Will activate the Finder but with a window on /Users/myHome/. Same thing with any open file: if you command-click on the file name on top of the file window you can select any folder on its path to have it open in Finder. Instead, the Finder opens /Users/myHome/.

Same thing with several applications that tell the Finder to reveal a file (not all apps: Music will correctly reveal track in Finder).

I have tried rebuilding the Spotlight index, checking the disk with Disk Utility, reinstalling Big Sur 11.4 but that does not fix the issue.

Any suggestion is welcome.

2
  • 1
    This is kind of an old-school trick, so I don't know if it still applies in Big Sur, but have you tried deleting the Finder preferences ('~/Library/Preferences/com.apple.finder.plist')? In older OSes that file would sometimes get corrupted, producing weird Finder behaviors. Drop the file in the trashcan and the relaunch the Finder; you may lose some finder preferences. Jun 13 at 14:01
  • It worked! Many thanks. Feel free to make that an answer, I will accept it gladly.
    – A.G.
    Jun 13 at 14:21
-1

Suggested by @TedWrigley: just delete the file ~/Library/Preferences/com.apple.finder.plist. This can be achived throught the Terminal:

rm ~/Library/Preferences/com.apple.finder.plist

Worked great.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .