Hi have a Macbook Air (previous model, no retina display). Ever since the Mojave update, Preview renders text in PDF files quite blurry compared to Adobe Acrobat.

For instance, here is a screenshot of a file rendered in Preview: enter image description here

Here is a screenshot of the same file, but rendered in Adobe Acrobat: enter image description here

You can see that the top image is noticeably blurry compared to the bottom image.

I've tried the tips suggested on this website, such as:

  1. Enabling or Disabling Font Smoothing in Settings
  2. Enabling Font Smoothing in Terminal
  3. Adjusting Font Smoothing Settings With Defaults

However, none of those suggestions fixed the blurry text rendering in Preview on my Macbook Air. Apparently, this is due to a change in the way that Mojave handles anti-aliasing compared to High Sierra. Is there a fix for this?

Here are the specs for my machine:

  Model Name:   MacBook Air
  Model Identifier: MacBookAir7,2
  Processor Name:   Intel Core i5
  Processor Speed:  1.8 GHz
  Number of Processors: 1
  Total Number of Cores:    2
  L2 Cache (per Core):  256 KB
  L3 Cache: 3 MB
  Memory:   8 GB

1 Answer 1


In short: No. Apple has removed the Font smoothing facility from the OS.

Your best option is to set Adobe Reader/Acrobat as your default app for PDFs. There are other apps, too. I quite like Foxit Reader, which is free and does display everything nice and crisply.

  • 1
    Thanks for the reply. That's too bad. Mojave has messed up more than just this for me. Oh well! Too late to go back now. I'll give Foxit Reader a try. Thanks!
    – kolipoki
    Apr 19, 2019 at 21:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .