0

I've been trying to get my iPhone audio to channel through my Mac, and what I read was that if I plug my iPhone into my Mac, I can open Audio MIDI setup and click "Enable" under the iPhone, and then it will be as I want it. Enable However, if I click enable, the word "iPhone" and a USB icon appear in the menu, with everything greyed out. Greyed out audio menu If I click the [name]'s iPhone with the iPhone next to it, It just says " Press the Enable button to place your iOS device in Inter-device Audio and MIDI Mode. In this mode, your iPhone or iPad will appear as an audio input device on your Mac, enabling the recording of non-telephony audio via the Lightning to USB cable. This setting also permits sending and receiving MIDI messages through the Lightning to USB cable using your favourite music applications" enter image description here There is no issue with USB lockdown or anything, because I can go into iTunes and sync my music, Podcasts, etc. I have tried playing music through the Apple Music app to check, but it plays through the iPhone speakers. Anyone know what the problem is here?

  • It enables the iPhone as an input source in apps like FaceTime etc, pick it as your input in there; it's already enabled & ready to go in audio/midi. Play something from iTunes to test. It doesn't feed the mic afaik, only 'non-telephony' audio. – Tetsujin Mar 12 '19 at 17:04
  • I did, but it played through the iPhone speakers. – John Mar 12 '19 at 18:19
  • Reboot both, try again. – Tetsujin Mar 12 '19 at 18:38
1

You just overlooked ther fact that by the time your iPhone button says "Disable", it is already connected!

Go to your Digital Audio Workstation (DAW)/Preferences/Audio and point to your iPhone as an Input Device.

In Ableton:

enter image description here

and in Logic Pro X for example:

enter image description here

Hope this helps!

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .