1

I'm trying to get Postfix working on my mac but I can not get it working.

Operating system is Mojave 10.14.3 MAMP PRO 5.2.2 I use a hostgator smtp which should work. It works anyway in my mail app.

I can not find any usable message and I have tried all kind of solutions which I found on internet but it still does not work.

By starting postfix in the terminal with "sudo postfix start" I get the message "fatal error".

How can I get postfix working on my Mac?

1

I'm in pretty much the same boat as you. The exception being I'm using mamp 4.5.

I'm yet to find a solution however I can help you to see the mail log.

in terminal you can use: log stream --predicate '(process == "smtpd") || (process == "smtp") || (process == "master")' -info

Using smarthost with the default mamp /etc/postfix/main.cf I keep getting: master: warning: process /usr/libexec/postfix/qmgr pid 9687 exit status 1 master: master exit time has arrived

I also get the same message if I turn mamp postfix off and activate it via terminal. For this I have followed https://benjaminrojas.net/configuring-postfix-to-send-mail-from-mac-os-x-mountain-lion/

with postconf -n I get the message postconf: warning: /etc/postfix/main.cf: unused parameter: mydomain_fallback=localhost

I hope this helps in some way.

0

Postfix should already be enabled to deliver email on your Mojave out of the box. You can test if its working by simply using the command line mail command:

mail username@gmail.com
Subject: test subject
test
.

One problem could be that the default outgoing mail port is being firewalled by your ISP.

Try running the above mail command in one terminal window while streaming the logs as suggested by anotherlatenight, in another. That should give you an idea what is failing.

-- However, if you want to relay through another host, GMAIL for example: add

[smtp.gmail.com]:587  username@gmail.com:password

to /etc/postfix/sasl_password. (you will need to use sudo) obviously replacing username and password...

Then

sudo postmap /etc/postfix/sasl_password

Then make sure the following are in your /etc/postfix/main.cf (from http://www.postfix.org/SASL_README.html#client_sasl)

relayhost=[smtp.gmail.com]:587

# Enable SASL authentication in the Postfix SMTP client.
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noplaintext, noanonymous
smtp_sasl_tls_security_options = noanonymous
smtp_tls_security_level = encrypt
smtp_sasl_mechanism_filter = AUTH LOGIN
smtp_use_tls = yes
smtp_tls_security_level = encrypt

You do not need to start postfix unless you want your Mac to be a mail server.

0

Sorry for my late reply. I will try this later. I have Postfix running now on my MacBook but it's not delivering mail in my mailbox.

Thanks for the answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .