0

The default MAMP's localhost document root is /Applications/MAMP/htdocs and I want to point it on my /Users/Me/Sites/ folder.

I can do easily with MAMP PRO GUI but it's not working after I restarted servers and it's showing me a red arrow (as an invalid destination):

enter image description here

I tried some solutions like:

  • Change default Apache port to 8888
  • Change default web user to me
  • Do an alias from MAMP htdocs folder to Sites folder
  • Do a symbolic link from MAMP htdocs folder to Sites folder
  • Try to set Sites folder owner (only) to me and group to Sites (but doesn't seem not work)
  • Set Sites permissions to 777, 755 and 750
  • Add an index.php file inside
  • Creating a new host

But MAMP still doesn't accept my Sites folder as document root! I tried with websites sub-folders inside Sites or with other Mac's personal folders like Music, Pictures, Downloads or my own home and they are working! Only Documents or Desktop folders don't work either.

It's seems a permission issue, but I don't know how to resolve it. Does it because Sites folder is used by other macOS apps or services?

Edit (27/07/2017): I opened an issue on official MAMP bugtracker: http://bugs.mamp.info/view.php?id=5945

Edit 2 (10/01/2018): From an official MAMP bugtracker administrator: "~/Sites will be allowed starting v4.3." (adb - 04.12.2017)

Edit 3 (07/02/2018): New MAMP v4.3 (released 24/01/2018) allows "~/Sites" as localhost root folder, watch my answer below.

  • This seems to be a cosmetic problem. Copying index.php and the png to the Sites folder and starting the server simply works here (though an invalid dir is indicated in MAMP PRO). – klanomath Oct 16 '17 at 8:54
  • Not only "cosmetic", because Apache or Nginx warnings are displayed each time servers are (re)started: "Some hosts have invalid disk location…" – Klemart3D Oct 16 '17 at 10:13
0

The localhost root folder to "~/Sites" is now allowed (from MAMP v4.3):

MAMP PRO v4.3 allows "~/Sites" localhost root folder

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .