On my 8 year-old 2010 MacBook Pro, I started getting a bunch of random shutdowns starting about a week ago. I reinstalled High Sierra after the first few, but I'm still getting them. Terminal reported the shutdown code -60 in all cases, which I understand is due to a bad master directory block.

However, I'm having none of the symptoms described in this post - the only thing going wrong with my computer is that it shuts down at random and unpredictable intervals (~1x a day). I sometimes get the kernel panic message, and sometimes I don't. Disk utility can find nothing wrong with my drive. As mentioned, I reinstalled the OS, and I ran disk utility after wiping the hard drive, plus I ran it after the most recent incident. The drive is a Samsung SSD that I self-installed about 5 years ago. I only just started getting these shutdowns. No issues with the drive that I can detect.

I'll note that my battery is extremely well-worn, but I basically keep the MBP plugged in nearly full-time, and all the incidents happened on AC power.

Any thoughts as to why this might be happening?

Results from running Disk Utility after the last shutdown are:

/dev/rdisk1s1: fsck_apfs started at Thu May 17 17:28:43 2018
/dev/rdisk1s1: ** Checking volume.
/dev/rdisk1s1: ** Checking the container superblock.
/dev/rdisk1s1: ** Checking the EFI jumpstart record.
/dev/rdisk1s1: ** Checking the space manager.
/dev/rdisk1s1: ** Checking the object map.
/dev/rdisk1s1: ** Checking the APFS volume superblock.
/dev/rdisk1s1: ** Checking the object map.
/dev/rdisk1s1: ** Checking the fsroot tree.
/dev/rdisk1s1: ** Checking the snapshot metadata tree.
/dev/rdisk1s1: ** Checking the extent ref tree.
/dev/rdisk1s1: ** Checking the snapshots.
/dev/rdisk1s1: ** Checking snapshot 1 of 9.
/dev/rdisk1s1: ** Checking snapshot 2 of 9.
/dev/rdisk1s1: ** Checking snapshot 3 of 9.
/dev/rdisk1s1: ** Checking snapshot 4 of 9.
/dev/rdisk1s1: ** Checking snapshot 5 of 9.
/dev/rdisk1s1: ** Checking snapshot 6 of 9.
/dev/rdisk1s1: ** Checking snapshot 7 of 9.
/dev/rdisk1s1: ** Checking snapshot 8 of 9.
/dev/rdisk1s1: ** Checking snapshot 9 of 9.
/dev/rdisk1s1: ** Verifying allocated space.
/dev/rdisk1s1: ** The volume /dev/rdisk1s1 appears to be OK.
/dev/rdisk1s1: fsck_apfs completed at Thu May 17 17:30:45 2018
  • That generation of MacBook Pro had an issue with the SATA cables especially since you've already changed out to an SSD. It's also posible that the SSD is failing. Try using an external drive to install macOS. If the problem goes away, you've narrowed down the issue to the drive and/or cable.
    – Allan
    Commented May 18, 2018 at 0:28
  • Also, get the SMART status. Issue the command diskutil info disk0 | grep SMART. Better yet, try to use a tool like DiskDrill to get detailed SMART info.
    – Allan
    Commented May 18, 2018 at 0:30
  • @Allan SMART status shows verified. I did reset the SMC as recommended on the other link. I did install High Sierra from a USB installer drive. Any other way to verify that the SATA cable is going?
    – Weiwen Ng
    Commented May 18, 2018 at 4:20
  • Install HS to an external drive and boot from that (not create a USB installer). Try DiskDrill as well.
    – Allan
    Commented May 18, 2018 at 4:56
  • If the SSD were failing, any thoughts on why I'm not getting any sort of error in Disk Utility, or why the SMART status isn't showing anything? Also, I'm not seeing any difficulty writing to the disk or booting. It doesn't yet look like any sort of drive or cable failure. Are there any possibilities apart from the drive or cable?
    – Weiwen Ng
    Commented May 18, 2018 at 13:18

1 Answer 1


@Allan suggested that the symptoms I reported were consistent with a failing SATA cable, which is a known issue. He suggested that I check the disk status with some utilities. I could find no disk issues when I did this.

The post I linked to earlier suggested resetting the SMC in addition to checking for disk errors. I reset the SMC. I have not experienced any unexplained shutdowns since. Any further errors, and I'll investigate that SATA cable.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .