I wish to turn off all animations in macOS. I'm following the steps provided in the answers to How to turn off all animations on OS X.

I wish to turn off animations on my MacBook Pro running macOS High Sierra 10.13.3 (17D102), but they don't appear to be working. I see no error message or any other message when I run the commands in the terminal. I tried logging out and logging back in but to no effect. How do I troubleshoot this or otherwise find a way to turn off as many animations as possible?

Note: I tried these 4 commands provided in the accepted answer to How to turn off all animations on OS X :

# opening and closing windows and popovers
defaults write -g NSAutomaticWindowAnimationsEnabled -bool false

# smooth scrolling
defaults write -g NSScrollAnimationEnabled -bool false

# showing and hiding sheets, resizing preference windows, zooming windows
# float 0 doesn't work
defaults write -g NSWindowResizeTime -float 0.001

# opening and closing Quick Look windows
defaults write -g QLPanelAnimationDuration -float 0
  • Please provide some details. What answers from the question, specifically what commands did you try? What animations specifically are you trying to turn off?
    – Nimesh Neema
    Mar 30, 2018 at 19:29
  • Have you restarted your computer? Often significant changes to the OS require a restart, not just a logout/login. Mar 30, 2018 at 19:38
  • They might have new names on High Sierra? Mar 31, 2018 at 8:41
  • How do I look up what the valid names are / what the names might have become?
    – dllahr
    Apr 1, 2018 at 16:50


You must log in to answer this question.

Browse other questions tagged .