I have added an additional SSD to my iMac and made it the startup disk. The old 1TB hard disk is still attached and is now the secondary hard drive.

The new drive is formatted to APFS. Old drive is still 'Mac OS extended (journaled)'


I want to fix the permission of my files on secondary hard drive such that I can easily manipulate my old files

What I have done:

I used Cmd+I to bring up the Info dialog box, and give antkong (Me) the read & write permission. Then I used 'apply to the enclosed items...' option to apply the new permission to subfolder and files.

It seems to work for me because the stop badges (minus in a red circle) on subfolders are gone.

enter image description here


I tried to delete some files in one of the subfolder. I still get prompted for the sudo password

enter image description here

I expect that I can manipulate files as if I am the owner.

Why this happens? How can I fix this issue?

1 Answer 1


The simplest method would be to check "Ignore ownership on this volume"

Get Info on the drive itself rather than an individual folder.
You should see the checkbox at the bottom, available once you unlock the admin padlock.

enter image description here

  • I didn't know this feature exists! Thanks for the answer. Unfortunately I really want to retain the permissions because it is a shared PC. I want other users to have read access only. Dec 13, 2017 at 22:17
  • Are the other users admins? If so they could just do this for themselves anyway. I'm wondering if adding a group would help your initial setup, rather than just owner & everyone.. [will run some tests...]
    – Tetsujin
    Dec 15, 2017 at 8:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .