2

corrupted Trash

Every day, permission of ~/.Trash is always gone(Pic1). And .Trash become zero bytes file.

That mean, I can't move files to Trash, and Finder will delete files immediately.

Every time ~/.Trash go wrong, I fix the problem by sudo rm -ri ~/.Trash and reboot mac, to create new Trash with normal permission. But, trash won't work again just after 1~2 hour.

  • (Permission of Trash on iCloud Drive is not affected-which means I can still remove files on iCloud Drive to trash.)

What I tried

  • sudo rm -ri ~/.Trash
  • remove and recreate .Trash on the iCloud path too.
  • use 'Appy enclosed items...' from home folder.
  • just don't use any kinds of 'optimization app' or 'cleaner app.'
  • reinstall clean macOS.
  • use disktuil on an internal drive and external drives.

Maybe...

I guess the problem comes with Time Machine backup, but I don't know why.

Because I found that, whenever Time Machine auto-backup starts and done, next time I boot the mac, it happens again.

It happens for both wired external Time machine drive and wireless drive on Nas, and it happens even I clean up the external drive and restart Time machine from the empty drive.

1

I solve the problem by checking which process use .Trash path by lsof | grep ~/.Trash

I found that the background service of VyprVPN app use /.Trash (still I don't know why). So I clean up VyprVPN app. Problem solved.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .