Installing macOS as a VM in VirtualBox
These instructions will guide you through the process of creating and using bootable media to install macOS in a VirtualBox VM.
Pre-Requisites
- Installer for for macOS (El Capitan, Sierra, High Sierra, etc.)
- VirtualBox 5.0+ (may work with older versions, but not tested)
- Newly created macOS VM created with standard settings (EFI, blank 60GB SSD, 128M video memory, 3D acceleration, 4GB RAM)
We are going to use the createinstallmedia
utility included with the macOS Install App to create a USB image. However, there's nothing that says it must be a physical USB device and not a disk image instead. For this we are going to use VB's ability to access a "raw" drive through a VMDK which will act as a pass-through device that VB can recognize and mount.
In the steps below, assume the working directory is the user's home (~/
).
Step 1: Create the Installation Media
Using hdiutil
create a sparse (expanding) disk image with a size of 6GB
hdiutil create -size 6GB -fs HFS+ -volname "macos-installation-media" -type SPARSE ~/macos-installation-media
Next, mount the image
hdiutil mount ~/macos-installation-media.sparseimage
You will get a message that looks similar to the one below. Pay attention to the disk identifier as you will need it in Step 2. In my environment, mine was disk7
your's will likely be different.
/dev/disk7 GUID_partition_scheme
/dev/disk7s1 EFI
/dev/disk7s2 Apple_HFS /Volumes/macos-installation-media
Finally, use createinstallmedia
from the macOS Installer to create the installation image:
sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/macos-installation-media --applicationpath /Applications/Install\ macOS\ Sierra.app/
Allow it to finish. When it's done it will automount the new Volume and you should see it on your Desktop.
The newly created image will need to be unmounted for the next step, so go ahead an unmount the disk.
diskutil unmountDisk /dev/disk7
Step 2: Create the VMDK
To do this, we are going to use VirtualBox's "raw hard disk access" to create a pass through to the newly created drive image.
The syntax of the command is as follows:
VBoxManage internalcommands createrawvmdk -filename </path/to/file>.vmdk -rawdisk /dev/disk#
So, for our purposes, the command would be (note the escaped spaces)
VBoxManage internalcommands createrawvmdk -filename ~/Install\ macOS\ Sierra.vmdk -rawdisk /dev/disk7
The VMDK will be a very small file that simply points to disk you created in Step 1. Now you can attach the VMDK to your VM and boot from it.
Add the VMDK to your VM and Boot
Before you can add the newly created VMDK to your VM, you need to take ownership of it. Since it was created using sudo
, root has ownership and rights. Be sure to replace "joeuser" with your username in the command example below:
sudo chown joeuser:staff Install\ macOS\ Sierra.vmdk
Using the VirtualBox GUI, select the desired VM, click Settings, click Storage, click Add Hard Disk button, select Choose existing drive, and then select the VMDK file you just created.
Boot your VM. VirtualBox will automatically find the bootable volume and begin the installation process.